p PatchFirst

CVE-2018-1000300

CVE-2018-1000300

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

curl version curl 7.54.1 to and including curl 7.59.0 contains a CWE-122: Heap-based Buffer Overflow vulnerability in denial of service and more that can result in curl might overflow a heap based memory buffer when closing down an FTP connection with very long server command replies.. This vulnerability appears to have been fixed in curl < 7.54.1 and curl >= 7.60.0.

CVSS 9.8 · Kritisch · EPSS 4,7% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • n/a

    Softwareversionen
    • n/a: Betroffen

    Keine Korrektur veröffentlicht

  • curl Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.60.0-1

    Auf 7.60.0-1 aktualisieren

  • curl Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.60.0-1

    Auf 7.60.0-1 aktualisieren

  • curl Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.60.0-1

    Auf 7.60.0-1 aktualisieren

  • curl Ubuntu:18.04:LTS

    Softwareversionen
    • 7.55.1-1ubuntu2
    • 7.55.1-1ubuntu2.1
    • 7.57.0-1ubuntu1
    • 7.58.0-2ubuntu1
    • 7.58.0-2ubuntu2
    • 7.58.0-2ubuntu3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.58.0-2ubuntu3.1

    Auf 7.58.0-2ubuntu3.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →