p PatchFirst

CVE-2019-1010174

CVE-2019-1010174

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

CImg The CImg Library v.2.3.3 and earlier is affected by: command injection. The impact is: RCE. The component is: load_network() function. The attack vector is: Loading an image from a user-controllable url can lead to command injection, because no string sanitization is done on the url. The fixed version is: v.2.3.4.

CVSS 9.8 · Kritisch · EPSS 5,0% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • the cimg library

    Softwareversionen
    • v.2.3.3 and earlier [fixed: v.2.3.4]: Betroffen

    Keine Korrektur veröffentlicht

  • cimg Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.3.6+dfsg-1

    Auf 2.3.6+dfsg-1 aktualisieren

  • cimg Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.3.6+dfsg-1

    Auf 2.3.6+dfsg-1 aktualisieren

  • cimg Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.3.6+dfsg-1

    Auf 2.3.6+dfsg-1 aktualisieren

  • cimg Ubuntu:16.04:LTS

    Softwareversionen
    • 1.6.4+dfsg-1build1
    • 1.6.5+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • gmic Ubuntu:16.04:LTS

    Softwareversionen
    • 1.6.2.0-1build2
    • 1.6.8-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • cimg Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1.7.9+dfsg-2
    • 1.7.9+dfsg-2build1
    • 1.7.9+dfsg-2ubuntu0.18.04.1
    • 1.7.9+dfsg-2ubuntu0.18.04.2
    • 1.7.9+dfsg-2ubuntu0.18.04.2+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • gmic Ubuntu:18.04:LTS

    Softwareversionen
    • 1.7.9+zart-4build1
    • 1.7.9+zart-4build2
    • 1.7.9+zart-4build3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • gmic Ubuntu:20.04:LTS

    Softwareversionen
    • 2.4.5-1
    • 2.4.5-1.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • gmic Ubuntu:22.04:LTS

    Softwareversionen
    • 2.9.4-4
    • 2.9.4-4build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →