CVE-2019-10131
CVE-2019-10131
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
An off-by-one read vulnerability was discovered in ImageMagick before version 7.0.7-28 in the formatIPTCfromBuffer function in coders/meta.c. A local attacker may use this flaw to read beyond the end of the buffer or to crash the program.
CVSS 6.5 · Mittel · EPSS 1,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
imagemagick
- Softwareversionen
- fixed in 7.0.7-28: Betroffen
Keine Korrektur veröffentlicht
imagemagick Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8:6.9.10.2+dfsg-2
Auf 8:6.9.10.2+dfsg-2 aktualisieren
imagemagick Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8:6.9.10.2+dfsg-2
Auf 8:6.9.10.2+dfsg-2 aktualisieren
imagemagick Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8:6.9.10.2+dfsg-2
Auf 8:6.9.10.2+dfsg-2 aktualisieren
imagemagick Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 8:6.7.7.10-5ubuntu3
- 8:6.7.7.10-5ubuntu4
- 8:6.7.7.10-6ubuntu1
- 8:6.7.7.10-6ubuntu2
- 8:6.7.7.10-6ubuntu3
- 8:6.7.7.10-6ubuntu3.1
- 8:6.7.7.10-6ubuntu3.2
- 8:6.7.7.10-6ubuntu3.3
- 8:6.7.7.10-6ubuntu3.4
- 8:6.7.7.10-6ubuntu3.5
- 8:6.7.7.10-6ubuntu3.6
- 8:6.7.7.10-6ubuntu3.7
- 8:6.7.7.10-6ubuntu3.8
- 8:6.7.7.10-6ubuntu3.9
- 8:6.7.7.10-6ubuntu3.11
- 8:6.7.7.10-6ubuntu3.12
- 8:6.7.7.10-6ubuntu3.13
- 8:6.7.7.10-6ubuntu3.13+esm1
- 8:6.7.7.10-6ubuntu3.13+esm2
- 8:6.7.7.10-6ubuntu3.13+esm3
- 8:6.7.7.10-6ubuntu3.13+esm4
- 8:6.7.7.10-6ubuntu3.13+esm5
- 8:6.7.7.10-6ubuntu3.13+esm6
- 8:6.7.7.10-6ubuntu3.13+esm7
- 8:6.7.7.10-6ubuntu3.13+esm8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8:6.7.7.10-6ubuntu3.13+esm9
Auf 8:6.7.7.10-6ubuntu3.13+esm9 aktualisieren
imagemagick Ubuntu:16.04:LTS
- Softwareversionen
- 8:6.8.9.9-5ubuntu2
- 8:6.8.9.9-6
- 8:6.8.9.9-6build1
- 8:6.8.9.9-7
- 8:6.8.9.9-7ubuntu1
- 8:6.8.9.9-7ubuntu2
- 8:6.8.9.9-7ubuntu3
- 8:6.8.9.9-7ubuntu4
- 8:6.8.9.9-7ubuntu5
- 8:6.8.9.9-7ubuntu5.1
- 8:6.8.9.9-7ubuntu5.2
- 8:6.8.9.9-7ubuntu5.3
- 8:6.8.9.9-7ubuntu5.4
- 8:6.8.9.9-7ubuntu5.5
- 8:6.8.9.9-7ubuntu5.6
- 8:6.8.9.9-7ubuntu5.7
- 8:6.8.9.9-7ubuntu5.8
- 8:6.8.9.9-7ubuntu5.9
- 8:6.8.9.9-7ubuntu5.11
- 8:6.8.9.9-7ubuntu5.12
- 8:6.8.9.9-7ubuntu5.13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8:6.8.9.9-7ubuntu5.14
Auf 8:6.8.9.9-7ubuntu5.14 aktualisieren
imagemagick Ubuntu:18.04:LTS
- Softwareversionen
- 8:6.9.7.4+dfsg-16ubuntu2
- 8:6.9.7.4+dfsg-16ubuntu3
- 8:6.9.7.4+dfsg-16ubuntu4
- 8:6.9.7.4+dfsg-16ubuntu5
- 8:6.9.7.4+dfsg-16ubuntu6
- 8:6.9.7.4+dfsg-16ubuntu6.2
- 8:6.9.7.4+dfsg-16ubuntu6.3
- 8:6.9.7.4+dfsg-16ubuntu6.4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8:6.9.7.4+dfsg-16ubuntu6.7
Auf 8:6.9.7.4+dfsg-16ubuntu6.7 aktualisieren
Originalquellen
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10131
- https://github.com/ImageMagick/ImageMagick/commit/cb1214c124e1bd61f7dd551b94a794864861592e
- http://www.securityfocus.com/bid/108117
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00051.html
- https://usn.ubuntu.com/4034-1/
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00001.html
- https://lists.debian.org/debian-lts-announce/2020/08/msg00030.html
- https://nvd.nist.gov/vuln/detail/CVE-2019-10131