p PatchFirst

CVE-2019-10184

CVE-2019-10184

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

undertow before version 2.0.23.Final is vulnerable to an information leak issue. Web apps may have their directory structures predicted through requests without trailing slashes via the api.

CVSS 5.3 · Mittel · EPSS 3,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • undertow

    Softwareversionen
    • fixed in 2.0.23.Final: Betroffen

    Keine Korrektur veröffentlicht

  • undertow Debian:14

    Softwareversionen
    • 1.3.11-1
    • 1.3.16-1
    • 1.3.19-1
    • 1.3.21-1
    • 1.3.23-1
    • 1.3.4-1
    • 1.3.5-1
    • 1.3.7-1
    • 1.4.0-1
    • 1.4.1-1
    • 1.4.18-1
    • 1.4.20-1
    • 1.4.21-1
    • 1.4.21-2
    • 1.4.22-1
    • 1.4.23-1
    • 1.4.23-2
    • 1.4.23-3
    • 1.4.25-1
    • 1.4.25-2
    • 1.4.3-1
    • 1.4.4-1
    • 1.4.6-1
    • 1.4.7-1
    • 1.4.8-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.0.23-1

    Auf 2.0.23-1 aktualisieren

  • undertow Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1.3.4-1
    • 1.3.5-1
    • 1.3.7-1
    • 1.3.11-1
    • 1.3.16-1
    • 1.3.16-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • undertow Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1.4.20-1
    • 1.4.21-1
    • 1.4.22-1
    • 1.4.23-1
    • 1.4.23-2build1
    • 1.4.23-3
    • 1.4.23-3ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • undertow Ubuntu:20.04:LTS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.0.23-1

    Auf 2.0.23-1 aktualisieren

  • undertow Ubuntu:Pro:24.04:LTS

    Softwareversionen
    • 2.3.8-2
    • 2.3.8-2ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • undertow Ubuntu:25.10

    Softwareversionen
    • 2.3.18-1
    • 2.3.18-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • undertow Ubuntu:26.10

    Softwareversionen
    • 2.3.20-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • undertow Ubuntu:26.04:LTS

    Softwareversionen
    • 2.3.18-2
    • 2.3.20-1
    • 2.3.20-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →