p PatchFirst

CVE-2019-1559

CVE-2019-1559 · 0-byte record padding oracle

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.

If an application encounters a fatal protocol error and then calls SSL_shutdown() twice (once to send a close_notify, and once to receive one) then OpenSSL can respond differently to the calling application if a 0 byte record is received with invalid padding compared to if a 0 byte record is received with an invalid MAC. If the application then behaves differently based on that in a way that is detectable to the remote peer, then this amounts to a padding oracle that could be used to decrypt data. In order for this to be exploitable "non-stitched" ciphersuites must be in use. Stitched ciphersuites are optimised implementations of certain commonly used ciphersuites. Also the application must call SSL_shutdown() twice even if a protocol error has occurred (applications should not do this but some do anyway). Fixed in OpenSSL 1.0.2r (Affected 1.0.2-1.0.2q).

CVSS 5.9 · Mittel · EPSS 17,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · network

Betroffene Produkte und Versionen

  • openssl

    Softwareversionen
    • Fixed in OpenSSL 1.0.2r (Affected 1.0.2-1.0.2q): Betroffen

    Keine Korrektur veröffentlicht

  • openssl Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.1.0b-2

    Auf 1.1.0b-2 aktualisieren

  • openssl Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.1.0b-2

    Auf 1.1.0b-2 aktualisieren

  • openssl Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.1.0b-2

    Auf 1.1.0b-2 aktualisieren

  • openssl Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 1.0.1e-3ubuntu1
    • 1.0.1e-4ubuntu1
    • 1.0.1e-4ubuntu2
    • 1.0.1e-4ubuntu3
    • 1.0.1e-4ubuntu4
    • 1.0.1f-1ubuntu1
    • 1.0.1f-1ubuntu2
    • 1.0.1f-1ubuntu2.1
    • 1.0.1f-1ubuntu2.2
    • 1.0.1f-1ubuntu2.3
    • 1.0.1f-1ubuntu2.4
    • 1.0.1f-1ubuntu2.5
    • 1.0.1f-1ubuntu2.7
    • 1.0.1f-1ubuntu2.8
    • 1.0.1f-1ubuntu2.11
    • 1.0.1f-1ubuntu2.12
    • 1.0.1f-1ubuntu2.15
    • 1.0.1f-1ubuntu2.16
    • 1.0.1f-1ubuntu2.17
    • 1.0.1f-1ubuntu2.18
    • 1.0.1f-1ubuntu2.19
    • 1.0.1f-1ubuntu2.20
    • 1.0.1f-1ubuntu2.21
    • 1.0.1f-1ubuntu2.22
    • 1.0.1f-1ubuntu2.23
    • 1.0.1f-1ubuntu2.24
    • 1.0.1f-1ubuntu2.25
    • 1.0.1f-1ubuntu2.26
    • 1.0.1f-1ubuntu2.27
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.0.1f-1ubuntu2.27+esm1

    Auf 1.0.1f-1ubuntu2.27+esm1 aktualisieren

  • openssl Ubuntu:16.04:LTS

    Softwareversionen
    • 1.0.2d-0ubuntu1
    • 1.0.2d-0ubuntu2
    • 1.0.2e-1ubuntu1
    • 1.0.2f-2ubuntu1
    • 1.0.2g-1ubuntu2
    • 1.0.2g-1ubuntu3
    • 1.0.2g-1ubuntu4
    • 1.0.2g-1ubuntu4.1
    • 1.0.2g-1ubuntu4.2
    • 1.0.2g-1ubuntu4.4
    • 1.0.2g-1ubuntu4.5
    • 1.0.2g-1ubuntu4.6
    • 1.0.2g-1ubuntu4.8
    • 1.0.2g-1ubuntu4.9
    • 1.0.2g-1ubuntu4.10
    • 1.0.2g-1ubuntu4.11
    • 1.0.2g-1ubuntu4.12
    • 1.0.2g-1ubuntu4.13
    • 1.0.2g-1ubuntu4.14
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.0.2g-1ubuntu4.15

    Auf 1.0.2g-1ubuntu4.15 aktualisieren

  • openssl1.0 Ubuntu:18.04:LTS

    Softwareversionen
    • 1.0.2n-1ubuntu2
    • 1.0.2n-1ubuntu3
    • 1.0.2n-1ubuntu4
    • 1.0.2n-1ubuntu5
    • 1.0.2n-1ubuntu5.1
    • 1.0.2n-1ubuntu5.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.0.2n-1ubuntu5.3

    Auf 1.0.2n-1ubuntu5.3 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →