p PatchFirst

CVE-2019-16763

CVE-2019-16763 · XSS in Pannellum from 2.5.0 through 2.5.4

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

In Pannellum from 2.5.0 through 2.5.4 URLs were not sanitized for data URIs (or vbscript:), allowing for potential XSS attacks. Such an attack would require a user to click on a hot spot to execute and would require an attacker-provided configuration. The most plausible potential attack would be if pannellum.htm was hosted on a domain that shared cookies with the targeted site's user authentication; an <iframe> could then be embedded on the attacker's site using pannellum.htm from the targeted site, which would allow the attacker to potentially access information from the targeted site as the authenticated user (or worse if the targeted site did not have adequate CSRF protections) if the user clicked on a hot spot in the attacker's embedded panorama viewer. This was patched in version 2.5.5.

CVSS 4.8 · Mittel · EPSS 0,7% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • pannellum

    Softwareversionen
    • 2.5.0: Betroffen
    • 2.5.1: Betroffen
    • 2.5.2: Betroffen
    • 2.5.3: Betroffen
    • 2.5.4: Betroffen

    Keine Korrektur veröffentlicht

  • pannellum npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.5.0, < 2.5.5

    Auf 2.5.5 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →