CVE-2020-11026
CVE-2020-11026 · Specially crafted filenames in WordPress leading to XSS
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
In affected versions of WordPress, files with a specially crafted name when uploaded to the Media section can lead to script execution upon accessing the file. This requires an authenticated user with privileges to upload files. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).
CVSS 8.7 · Hoch · EPSS 2,1% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
wordpress
- Softwareversionen
- >= 5.4.0, < 5.4.1: Betroffen
- >= 5.3.0, < 5.3.3: Betroffen
- >= 5.2.0, < 5.2.6: Betroffen
- >= 5.1.0, < 5.1.5: Betroffen
- >= 5.0.0, < 5.0.9: Betroffen
- >= 4.9.0, < 4.9.14: Betroffen
- >= 4.8.0, < 4.8.13: Betroffen
- >= 4.7.0, < 4.7.17: Betroffen
- >= 4.6.0, < 4.6.18: Betroffen
- >= 4.5.0, < 4.5.21: Betroffen
- >= 4.4.0, < 4.4.22: Betroffen
- >= 4.3.0, < 4.3.23: Betroffen
- >= 4.2.0, < 4.2.27: Betroffen
- >= 4.1.0, < 4.1.30: Betroffen
- >= 4.0.0, < 4.0.30: Betroffen
- >= 3.9.0, < 3.9.31: Betroffen
- >= 3.8.0, < 3.8.33: Betroffen
- >= 3.7.0, < 3.7.33: Betroffen
Keine Korrektur veröffentlicht
wordpress Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.4.1+dfsg1-1
Auf 5.4.1+dfsg1-1 aktualisieren
wordpress Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.4.1+dfsg1-1
Auf 5.4.1+dfsg1-1 aktualisieren
wordpress Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.4.1+dfsg1-1
Auf 5.4.1+dfsg1-1 aktualisieren
wordpress Ubuntu:16.04:LTS
- Softwareversionen
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
wordpress Ubuntu:18.04:LTS
- Softwareversionen
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
wordpress Ubuntu:20.04:LTS
- Softwareversionen
- 5.2.2+dfsg1-1
- 5.2.4+dfsg1-1
- 5.3.2+dfsg1-1
- 5.3.2+dfsg1-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
wordpress Ubuntu:22.04:LTS
- Softwareversionen
- 5.7.1+dfsg1-2ubuntu1
- 5.8.1+dfsg1-2ubuntu1
- 5.8.2+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
wordpress Ubuntu:24.04:LTS
- Softwareversionen
- 6.2+dfsg1-1ubuntu1
- 6.4.3+dfsg1-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
wordpress Ubuntu:25.10
- Softwareversionen
- 6.7.2+dfsg1-1.1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
wordpress Ubuntu:26.10
- Softwareversionen
- 6.7.2+dfsg1-1.1ubuntu2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
wordpress Ubuntu:26.04:LTS
- Softwareversionen
- 6.7.2+dfsg1-1.1ubuntu1
- 6.7.2+dfsg1-1.1ubuntu2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://wordpress.org/support/wordpress-version/version-5-4-1/#security-updates
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-3gw2-4656-pfr2
- https://www.debian.org/security/2020/dsa-4677
- https://lists.debian.org/debian-lts-announce/2020/05/msg00011.html
- https://nvd.nist.gov/vuln/detail/CVE-2020-11026