p PatchFirst

CVE-2020-14422

CVE-2020-14422

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.

Lib/ipaddress.py in Python through 3.8.3 improperly computes hash values in the IPv4Interface and IPv6Interface classes, which might allow a remote attacker to cause a denial of service if an application is affected by the performance of a dictionary containing IPv4Interface or IPv6Interface objects, and this attacker can cause many dictionary entries to be created. This is fixed in: v3.5.10, v3.5.10rc1; v3.6.12; v3.7.9; v3.8.4, v3.8.4rc1, v3.8.5, v3.8.6, v3.8.6rc1; v3.9.0, v3.9.0b4, v3.9.0b5, v3.9.0rc1, v3.9.0rc2.

CVSS 5.9 · Mittel · EPSS 12,7% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • n/a

    Softwareversionen
    • n/a: Betroffen

    Keine Korrektur veröffentlicht

  • python-ipaddress Debian:11

    Softwareversionen
    • 1.0.23-1
    • 1.0.23-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • python3.4 Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 3.4~b1-0ubuntu3
    • 3.4~b1-4ubuntu4
    • 3.4~b1-4ubuntu6
    • 3.4~b1-5ubuntu2
    • 3.4~b2-1
    • 3.4~b3-1ubuntu1
    • 3.4~rc1-1build1
    • 3.4~rc2-1
    • 3.4~rc3-0ubuntu1
    • 3.4.0-1
    • 3.4.0-2ubuntu1
    • 3.4.0-2ubuntu1.1
    • 3.4.3-1ubuntu1~14.04.1
    • 3.4.3-1ubuntu1~14.04.3
    • 3.4.3-1ubuntu1~14.04.4
    • 3.4.3-1ubuntu1~14.04.5
    • 3.4.3-1ubuntu1~14.04.6
    • 3.4.3-1ubuntu1~14.04.7
    • 3.4.3-1ubuntu1~14.04.7+esm2
    • 3.4.3-1ubuntu1~14.04.7+esm4
    • 3.4.3-1ubuntu1~14.04.7+esm6
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.4.3-1ubuntu1~14.04.7+esm7

    Auf 3.4.3-1ubuntu1~14.04.7+esm7 aktualisieren

  • python3.5 Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 3.5.2-2ubuntu0~16.04.4~14.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.5.2-2ubuntu0~16.04.4~14.04.1+esm1

    Auf 3.5.2-2ubuntu0~16.04.4~14.04.1+esm1 aktualisieren

  • python3.5 Ubuntu:16.04:LTS

    Softwareversionen
    • 3.5.0-3
    • 3.5.0-3ubuntu1
    • 3.5.1~rc1-2ubuntu1
    • 3.5.1-1
    • 3.5.1-2
    • 3.5.1-3
    • 3.5.1-5
    • 3.5.1-6ubuntu1
    • 3.5.1-6ubuntu2
    • 3.5.1-9ubuntu1
    • 3.5.1-10
    • 3.5.2-2~16.01
    • 3.5.2-2~16.04
    • 3.5.2-2ubuntu0~16.04.1
    • 3.5.2-2ubuntu0~16.04.2
    • 3.5.2-2ubuntu0~16.04.3
    • 3.5.2-2ubuntu0~16.04.4
    • 3.5.2-2ubuntu0~16.04.5
    • 3.5.2-2ubuntu0~16.04.8
    • 3.5.2-2ubuntu0~16.04.9
    • 3.5.2-2ubuntu0~16.04.10
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.5.2-2ubuntu0~16.04.11

    Auf 3.5.2-2ubuntu0~16.04.11 aktualisieren

  • python3.6 Ubuntu:18.04:LTS

    Softwareversionen
    • 3.6.3-1ubuntu1
    • 3.6.4~rc1-1
    • 3.6.4~rc1-2
    • 3.6.4-1
    • 3.6.4-2
    • 3.6.4-3build1
    • 3.6.4-4
    • 3.6.5~rc1-1
    • 3.6.5-3
    • 3.6.6-1~18.04
    • 3.6.7-1~18.04
    • 3.6.8-1~18.04.1
    • 3.6.8-1~18.04.2
    • 3.6.8-1~18.04.3
    • 3.6.9-1~18.04
    • 3.6.9-1~18.04ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.6.9-1~18.04ubuntu1.1

    Auf 3.6.9-1~18.04ubuntu1.1 aktualisieren

  • python3.7 Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 3.7.0~a2-1
    • 3.7.0~a3-1
    • 3.7.0~a3-2
    • 3.7.0~a3-3
    • 3.7.0~a4-1
    • 3.7.0~b1-1
    • 3.7.0~b1-1build1
    • 3.7.0~b2-1
    • 3.7.0~b3-1
    • 3.7.0-1~18.04
    • 3.7.1-1~18.04
    • 3.7.3-2~18.04.1
    • 3.7.5-2~18.04
    • 3.7.5-2~18.04.4
    • 3.7.5-2ubuntu1~18.04.2
    • 3.7.5-2ubuntu1~18.04.2+esm1
    • 3.7.5-2ubuntu1~18.04.2+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.7.5-2ubuntu1~18.04.2+esm3

    Auf 3.7.5-2ubuntu1~18.04.2+esm3 aktualisieren

  • python3.8 Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 3.8.0-3~18.04
    • 3.8.0-3~18.04.1
    • 3.8.0-3ubuntu1~18.04.2
    • 3.8.0-3ubuntu1~18.04.2+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.8.0-3ubuntu1~18.04.2+esm2

    Auf 3.8.0-3ubuntu1~18.04.2+esm2 aktualisieren

  • python3.8 Ubuntu:20.04:LTS

    Softwareversionen
    • 3.8.0-1
    • 3.8.0-2
    • 3.8.0-3
    • 3.8.0-4
    • 3.8.0-5
    • 3.8.1-2ubuntu3
    • 3.8.2~rc1-1ubuntu1
    • 3.8.2-1
    • 3.8.2-1ubuntu1
    • 3.8.2-1ubuntu1.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.8.2-1ubuntu1.2

    Auf 3.8.2-1ubuntu1.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →