p PatchFirst

CVE-2020-1752

CVE-2020-1752

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A use-after-free vulnerability introduced in glibc upstream version 2.14 was found in the way the tilde expansion was carried out. Directory paths containing an initial tilde followed by a valid username were affected by this issue. A local attacker could exploit this flaw by creating a specially crafted path that, when processed by the glob function, would potentially lead to arbitrary code execution. This was fixed in version 2.32.

CVSS 7.0 · Hoch · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • glibc

    Softwareversionen
    • Affected: versions 2.14 and later: Betroffen
    • Fixed: version 2.32: Betroffen

    Keine Korrektur veröffentlicht

  • glibc Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.30-3

    Auf 2.30-3 aktualisieren

  • glibc Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.30-3

    Auf 2.30-3 aktualisieren

  • glibc Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.30-3

    Auf 2.30-3 aktualisieren

  • eglibc Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 2.17-93ubuntu4
    • 2.18-0ubuntu1
    • 2.18-0ubuntu2
    • 2.18-0ubuntu4
    • 2.18-0ubuntu5
    • 2.18-0ubuntu6
    • 2.18-0ubuntu7
    • 2.19-0ubuntu2
    • 2.19-0ubuntu3
    • 2.19-0ubuntu4
    • 2.19-0ubuntu5
    • 2.19-0ubuntu6
    • 2.19-0ubuntu6.1
    • 2.19-0ubuntu6.3
    • 2.19-0ubuntu6.4
    • 2.19-0ubuntu6.5
    • 2.19-0ubuntu6.6
    • 2.19-0ubuntu6.7
    • 2.19-0ubuntu6.8
    • 2.19-0ubuntu6.9
    • 2.19-0ubuntu6.10
    • 2.19-0ubuntu6.11
    • 2.19-0ubuntu6.13
    • 2.19-0ubuntu6.14
    • 2.19-0ubuntu6.15
    • 2.19-0ubuntu6.15+esm1
    • 2.19-0ubuntu6.15+esm2
    • 2.19-0ubuntu6.15+esm3
    • 2.19-0ubuntu6.15+esm4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • glibc Ubuntu:16.04:LTS

    Softwareversionen
    • 2.21-0ubuntu4
    • 2.21-0ubuntu5
    • 2.21-0ubuntu6
    • 2.23-0ubuntu1
    • 2.23-0ubuntu2
    • 2.23-0ubuntu3
    • 2.23-0ubuntu4
    • 2.23-0ubuntu5
    • 2.23-0ubuntu6
    • 2.23-0ubuntu7
    • 2.23-0ubuntu9
    • 2.23-0ubuntu10
    • 2.23-0ubuntu11
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.23-0ubuntu11.2

    Auf 2.23-0ubuntu11.2 aktualisieren

  • glibc Ubuntu:18.04:LTS

    Softwareversionen
    • 2.26-0ubuntu2
    • 2.26-0ubuntu2.1
    • 2.27-0ubuntu2
    • 2.27-0ubuntu3
    • 2.27-3ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.27-3ubuntu1.2

    Auf 2.27-3ubuntu1.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →