p PatchFirst

CVE-2020-25629

CVE-2020-25629

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A vulnerability was found in Moodle where users with "Log in as" capability in a course context (typically, course managers) may gain access to some site administration capabilities by "logging in as" a System manager. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. This is fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.

CVSS 8.8 · Hoch · EPSS 1,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · php

Betroffene Produkte und Versionen

  • moodle

    Softwareversionen
    • 3.9 to 3.9.1: Betroffen
    • 3.8 to 3.8.4: Betroffen
    • 3.7 to 3.7.7: Betroffen
    • 3.5 to 3.5.13: Betroffen
    • earlier unsupported versions: Betroffen

    Keine Korrektur veröffentlicht

  • moodle/moodle Packagist

    Softwareversionen
    • v3.9.0
    • v3.9.0-beta
    • v3.9.0-rc1
    • v3.9.0-rc2
    • v3.9.0-rc3
    • v3.9.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.9, < 3.9.2

    Auf 3.9.2 aktualisieren

  • moodle/moodle Packagist

    Softwareversionen
    • v3.8.0
    • v3.8.0-beta
    • v3.8.0-rc1
    • v3.8.1
    • v3.8.2
    • v3.8.3
    • v3.8.4
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.8, < 3.8.5

    Auf 3.8.5 aktualisieren

  • moodle/moodle Packagist

    Softwareversionen
    • v3.7.0
    • v3.7.0-beta
    • v3.7.0-rc1
    • v3.7.0-rc2
    • v3.7.1
    • v3.7.2
    • v3.7.3
    • v3.7.4
    • v3.7.5
    • v3.7.6
    • v3.7.7
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.7, < 3.7.8

    Auf 3.7.8 aktualisieren

  • moodle/moodle Packagist

    Softwareversionen
    • v3.5.0
    • v3.5.0-beta
    • v3.5.0-rc1
    • v3.5.1
    • v3.5.10
    • v3.5.11
    • v3.5.12
    • v3.5.13
    • v3.5.2
    • v3.5.3
    • v3.5.4
    • v3.5.5
    • v3.5.6
    • v3.5.7
    • v3.5.8
    • v3.5.9
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.5, < 3.5.14

    Auf 3.5.14 aktualisieren

  • moodle Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 2.7.9+dfsg-1
    • 2.7.10+dfsg-1
    • 2.7.11+dfsg-1
    • 2.7.11+dfsg-2
    • 2.7.12+dfsg-1
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • moodle Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →