CVE-2020-26270
CVE-2020-26270 · CHECK-fail in LSTM with zero-length input in TensorFlow
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
In affected versions of TensorFlow running an LSTM/GRU model where the LSTM/GRU layer receives an input with zero-length results in a CHECK failure when using the CUDA backend. This can result in a query-of-death vulnerability, via denial of service, if users can control the input to the layer. This is fixed in versions 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2, and 2.4.0.
CVSS 4.4 · Mittel · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
tensorflow
- Softwareversionen
- < 1.15.5: Betroffen
- >= 2.0.0, < 2.0.4: Betroffen
- >= 2.1.0, < 2.1.3: Betroffen
- >= 2.2.0, < 2.2.2: Betroffen
- >= 2.3.0, < 2.3.2: Betroffen
Keine Korrektur veröffentlicht
tensorflow PyPI
- Softwareversionen
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.15.4
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.15.5
Auf 1.15.5 aktualisieren
tensorflow PyPI
- Softwareversionen
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0.0, < 2.0.4
Auf 2.0.4 aktualisieren
tensorflow PyPI
- Softwareversionen
- 2.1.0
- 2.1.1
- 2.1.2
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.1.0, < 2.1.3
Auf 2.1.3 aktualisieren
tensorflow PyPI
- Softwareversionen
- 2.2.0
- 2.2.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.2.0, < 2.2.2
Auf 2.2.2 aktualisieren
tensorflow PyPI
- Softwareversionen
- 2.3.0
- 2.3.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.3.0, < 2.3.2
Auf 2.3.2 aktualisieren
tensorflow-cpu PyPI
- Softwareversionen
- 1.15.0
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.15.5
Auf 1.15.5 aktualisieren
tensorflow-cpu PyPI
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0.0, < 2.0.4
Auf 2.0.4 aktualisieren
tensorflow-cpu PyPI
- Softwareversionen
- 2.1.0
- 2.1.1
- 2.1.2
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.1.0, < 2.1.3
Auf 2.1.3 aktualisieren
tensorflow-cpu PyPI
- Softwareversionen
- 2.2.0
- 2.2.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.2.0, < 2.2.2
Auf 2.2.2 aktualisieren
tensorflow-cpu PyPI
- Softwareversionen
- 2.3.0
- 2.3.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.3.0, < 2.3.2
Auf 2.3.2 aktualisieren
tensorflow-gpu PyPI
- Softwareversionen
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.15.4
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.15.5
Auf 1.15.5 aktualisieren
tensorflow-gpu PyPI
- Softwareversionen
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0.0, < 2.0.4
Auf 2.0.4 aktualisieren
tensorflow-gpu PyPI
- Softwareversionen
- 2.1.0
- 2.1.1
- 2.1.2
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.1.0, < 2.1.3
Auf 2.1.3 aktualisieren
tensorflow-gpu PyPI
- Softwareversionen
- 2.2.0
- 2.2.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.2.0, < 2.2.2
Auf 2.2.2 aktualisieren
tensorflow-gpu PyPI
- Softwareversionen
- 2.3.0
- 2.3.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.3.0, < 2.3.2
Auf 2.3.2 aktualisieren
tensorflow PyPI
- Softwareversionen
- 0.12.0
- 0.12.0rc0
- 0.12.0rc1
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.1.0rc0
- 1.1.0rc1
- 1.1.0rc2
- 1.10.0
- 1.10.0rc0
- 1.10.0rc1
- 1.10.1
- 1.11.0
- 1.11.0rc0
- 1.11.0rc1
- 1.11.0rc2
- 1.12.0
- 1.12.0rc0
- 1.12.0rc1
- 1.12.0rc2
- 1.12.2
- 1.12.3
- 1.13.0rc0
- 1.13.0rc1
- 1.13.0rc2
- 1.13.1
- 1.13.2
- 1.14.0
- 1.14.0rc0
- 1.14.0rc1
- 1.15.0
- 1.15.0rc0
- 1.15.0rc1
- 1.15.0rc2
- 1.15.0rc3
- 1.15.2
- 1.15.3
- 1.15.4
- 1.2.0
- 1.2.0rc0
- 1.2.0rc1
- 1.2.0rc2
- 1.2.1
- 1.3.0
- 1.3.0rc0
- 1.3.0rc1
- 1.3.0rc2
- 1.4.0
- 1.4.0rc0
- 1.4.0rc1
- 1.4.1
- 1.5.0
- 1.5.0rc0
- 1.5.0rc1
- 1.5.1
- 1.6.0
- 1.6.0rc0
- 1.6.0rc1
- 1.7.0
- 1.7.0rc0
- 1.7.0rc1
- 1.7.1
- 1.8.0
- 1.8.0rc0
- 1.8.0rc1
- 1.9.0
- 1.9.0rc0
- 1.9.0rc1
- 1.9.0rc2
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.1.0
- 2.1.1
- 2.1.2
- 2.2.0
- 2.2.1
- 2.3.0
- 2.3.1
- Betroffene Versionsbereiche
- GIT: < 14755416e364f17fb1870882fa778c7fec7f16e3
- ECOSYSTEM: < 1.15.5 ∪ ≥ 2.0.0, < 2.0.4 ∪ ≥ 2.1.0, < 2.1.3 ∪ ≥ 2.2.0, < 2.2.2 ∪ ≥ 2.3.0, < 2.3.2
Auf 1.15.5 aktualisieren; Auf 2.0.4 aktualisieren; Auf 2.1.3 aktualisieren; Auf 2.2.2 aktualisieren; Auf 2.3.2 aktualisieren
tensorflow-cpu PyPI
- Softwareversionen
- 1.15.0
- 2.1.0
- 2.1.1
- 2.1.2
- 2.2.0
- 2.2.1
- 2.3.0
- 2.3.1
- Betroffene Versionsbereiche
- GIT: < 14755416e364f17fb1870882fa778c7fec7f16e3
- ECOSYSTEM: < 1.15.5 ∪ ≥ 2.0.0, < 2.0.4 ∪ ≥ 2.1.0, < 2.1.3 ∪ ≥ 2.2.0, < 2.2.2 ∪ ≥ 2.3.0, < 2.3.2
Auf 1.15.5 aktualisieren; Auf 2.0.4 aktualisieren; Auf 2.1.3 aktualisieren; Auf 2.2.2 aktualisieren; Auf 2.3.2 aktualisieren
tensorflow-gpu PyPI
- Softwareversionen
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.15.4
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.1.0
- 2.1.1
- 2.1.2
- 2.2.0
- 2.2.1
- 2.3.0
- 2.3.1
- Betroffene Versionsbereiche
- GIT: < 14755416e364f17fb1870882fa778c7fec7f16e3
- ECOSYSTEM: < 1.15.5 ∪ ≥ 2.0.0, < 2.0.4 ∪ ≥ 2.1.0, < 2.1.3 ∪ ≥ 2.2.0, < 2.2.2 ∪ ≥ 2.3.0, < 2.3.2
Auf 1.15.5 aktualisieren; Auf 2.0.4 aktualisieren; Auf 2.1.3 aktualisieren; Auf 2.2.2 aktualisieren; Auf 2.3.2 aktualisieren