p PatchFirst

CVE-2020-36632

CVE-2020-36632 · hughsk flat index.js unflatten prototype pollution

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A vulnerability, which was classified as critical, was found in hughsk flat up to 5.0.0. This affects the function unflatten of the file index.js. The manipulation leads to improperly controlled modification of object prototype attributes ('prototype pollution'). It is possible to initiate the attack remotely. Upgrading to version 5.0.1 is able to address this issue. The name of the patch is 20ef0ef55dfa028caddaedbcb33efbdb04d18e13. It is recommended to upgrade the affected component. The identifier VDB-216777 was assigned to this vulnerability.

CVSS 6.3 · Mittel · EPSS 1,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • flat

    Softwareversionen
    • 5.0: Betroffen

    Keine Korrektur veröffentlicht

  • flat npm

    Betroffene Versionsbereiche
    • SEMVER: < 1.6.2

    Auf 1.6.2 aktualisieren

  • flat npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.0.0, < 2.0.2

    Auf 2.0.2 aktualisieren

  • flat npm

    Softwareversionen
    • 3.0.0
    Betroffene Versionsbereiche
    • SEMVER: ≥ 3.0.0, < 3.0.1

    Auf 3.0.1 aktualisieren

  • flat npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.0.0, < 4.0.2

    Auf 4.0.2 aktualisieren

  • flat npm

    Softwareversionen
    • 5.0.0
    Betroffene Versionsbereiche
    • SEMVER: ≥ 5.0.0, < 5.0.1

    Auf 5.0.1 aktualisieren

  • qt6-webengine Ubuntu:22.04:LTS

    Softwareversionen
    • 6.2.2+dfsg-6ubuntu2
    • 6.2.4+dfsg-1ubuntu1
    • 6.2.4+dfsg-1ubuntu2
    • 6.2.4+dfsg-6ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • qt6-webengine Ubuntu:24.04:LTS

    Softwareversionen
    • 6.4.2-final+dfsg-11
    • 6.4.2-final+dfsg-12
    • 6.4.2-final+dfsg-12build1
    • 6.4.2-final+dfsg-12ubuntu1
    • 6.4.2-final+dfsg-12ubuntu7
    • 6.4.2-final+dfsg-12ubuntu9
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • qt6-webengine Ubuntu:25.10

    Softwareversionen
    • 6.8.3+dfsg-0ubuntu1
    • 6.8.3+dfsg-0ubuntu2
    • 6.9.2+dfsg-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • qt6-webengine Ubuntu:26.10

    Softwareversionen
    • 6.10.2+dfsg-1
    • 6.10.2+dfsg-4
    • 6.10.2+dfsg-5
    • 6.11.2+dfsg-3ubuntu1
    • 6.11.2+dfsg-3ubuntu2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • qt6-webengine Ubuntu:26.04:LTS

    Softwareversionen
    • 6.9.2+dfsg-2
    • 6.9.2+dfsg-4
    • 6.9.2+dfsg-4build1
    • 6.9.2+dfsg-4build2
    • 6.10.2+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →