CVE-2020-4047
CVE-2020-4047 · Authenticated XSS via media attachment page in WordPress
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
In affected versions of WordPress, authenticated users with upload permissions (like authors) are able to inject JavaScript into some media file attachment pages in a certain way. This can lead to script execution in the context of a higher privileged user when the file is viewed by them. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).
CVSS 6.8 · Mittel · EPSS 3,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
wordpress-develop
- Softwareversionen
- >= 5.4.0, < 5.4.2: Betroffen
- >= 5.3.0, < 5.3.4: Betroffen
- >= 5.2.0, < 5.2.7: Betroffen
- >= 5.1.0, < 5.1.6: Betroffen
- >= 5.0.0, < 5.0.10: Betroffen
- >= 4.9.0, < 4.9.15: Betroffen
- >= 4.8.0, < 4.8.14: Betroffen
- >= 4.7.0, < 4.7.18: Betroffen
- >= 4.6.0, < 4.6.19: Betroffen
- >= 4.5.0, < 4.5.22: Betroffen
- >= 4.4.0, < 4.4.23: Betroffen
- >= 4.3.0, < 4.3.24: Betroffen
- >= 4.2.0, < 4.2.28: Betroffen
- >= 4.1.0, < 4.1.31: Betroffen
- >= 4.0.0, < 4.0.31: Betroffen
- >= 3.9.0, < 3.9.32: Betroffen
- >= 3.8.0, < 3.8.34: Betroffen
- >= 3.7.0, < 3.7.34: Betroffen
Keine Korrektur veröffentlicht
wordpress Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.4.2+dfsg1-1
Auf 5.4.2+dfsg1-1 aktualisieren
wordpress Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.4.2+dfsg1-1
Auf 5.4.2+dfsg1-1 aktualisieren
wordpress Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.4.2+dfsg1-1
Auf 5.4.2+dfsg1-1 aktualisieren
wordpress Ubuntu:16.04:LTS
- Softwareversionen
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
wordpress Ubuntu:18.04:LTS
- Softwareversionen
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
wordpress Ubuntu:20.04:LTS
- Softwareversionen
- 5.2.2+dfsg1-1
- 5.2.4+dfsg1-1
- 5.3.2+dfsg1-1
- 5.3.2+dfsg1-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
wordpress Ubuntu:22.04:LTS
- Softwareversionen
- 5.7.1+dfsg1-2ubuntu1
- 5.8.1+dfsg1-2ubuntu1
- 5.8.2+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://wordpress.org/news/2020/06/wordpress-5-4-2-security-and-maintenance-release/
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-8q2w-5m27-wm27
- https://github.com/WordPress/wordpress-develop/commit/0977c0d6b241479ecedfe19e96be69f727c3f81f
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ODNHXVJS25YVWYQHOCICXTLIN5UYJFDN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/773N2ZV7QEMBGKH6FBKI6Q5S3YJMW357/
- https://www.debian.org/security/2020/dsa-4709
- https://lists.debian.org/debian-lts-announce/2020/07/msg00000.html
- https://lists.debian.org/debian-lts-announce/2020/09/msg00011.html
- https://nvd.nist.gov/vuln/detail/CVE-2020-4047