p PatchFirst

CVE-2020-4050

CVE-2020-4050 · set-screen-option filter misuse by plugins leading to privilege escalation in WordPress

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

In affected versions of WordPress, misuse of the `set-screen-option` filter's return value allows arbitrary user meta fields to be saved. It does require an admin to install a plugin that would misuse the filter. Once installed, it can be leveraged by low privileged users. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).

CVSS 3.5 · Niedrig · EPSS 1,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • wordpress-develop

    Softwareversionen
    • >= 5.4.0, < 5.4.2: Betroffen
    • >= 5.3.0, < 5.3.4: Betroffen
    • >= 5.2.0, < 5.2.7: Betroffen
    • >= 5.1.0, < 5.1.6: Betroffen
    • >= 5.0.0, < 5.0.10: Betroffen
    • >= 4.9.0, < 4.9.15: Betroffen
    • >= 4.8.0, < 4.8.14: Betroffen
    • >= 4.7.0, < 4.7.18: Betroffen
    • >= 4.6.0, < 4.6.19: Betroffen
    • >= 4.5.0, < 4.5.22: Betroffen
    • >= 4.4.0, < 4.4.23: Betroffen
    • >= 4.3.0, < 4.3.24: Betroffen
    • >= 4.2.0, < 4.2.28: Betroffen
    • >= 4.1.0, < 4.1.31: Betroffen
    • >= 4.0.0, < 4.0.31: Betroffen
    • >= 3.9.0, < 3.9.32: Betroffen
    • >= 3.8.0, < 3.8.34: Betroffen
    • >= 3.7.0, < 3.7.34: Betroffen

    Keine Korrektur veröffentlicht

  • wordpress Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.4.2+dfsg1-1

    Auf 5.4.2+dfsg1-1 aktualisieren

  • wordpress Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.4.2+dfsg1-1

    Auf 5.4.2+dfsg1-1 aktualisieren

  • wordpress Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.4.2+dfsg1-1

    Auf 5.4.2+dfsg1-1 aktualisieren

  • wordpress Ubuntu:16.04:LTS

    Softwareversionen
    • 4.3+dfsg-1
    • 4.3.1+dfsg-1
    • 4.4+dfsg-1
    • 4.4.1+dfsg-1
    • 4.4.2+dfsg-1
    • 4.4.2+dfsg-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • wordpress Ubuntu:18.04:LTS

    Softwareversionen
    • 4.8.2+dfsg-2
    • 4.8.3+dfsg-1
    • 4.9.1+dfsg-1
    • 4.9.2+dfsg-1
    • 4.9.4+dfsg-1
    • 4.9.5+dfsg1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • wordpress Ubuntu:20.04:LTS

    Softwareversionen
    • 5.2.2+dfsg1-1
    • 5.2.4+dfsg1-1
    • 5.3.2+dfsg1-1
    • 5.3.2+dfsg1-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • wordpress Ubuntu:22.04:LTS

    Softwareversionen
    • 5.7.1+dfsg1-2ubuntu1
    • 5.8.1+dfsg1-2ubuntu1
    • 5.8.2+dfsg1-1ubuntu1
    • 5.8.3+dfsg1-1ubuntu1
    • 5.8.3+dfsg1-1ubuntu1.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →