p PatchFirst

CVE-2021-20304

CVE-2021-20304

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A flaw was found in OpenEXR's hufDecode functionality. This flaw allows an attacker who can pass a crafted file to be processed by OpenEXR, to trigger an undefined right shift error. The highest threat from this vulnerability is to system availability.

CVSS 7.5 · Hoch · EPSS 2,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • openexr

    Softwareversionen
    • Fixed in OpenEXR 3.0.0-beta: Betroffen

    Keine Korrektur veröffentlicht

  • openexr Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.5.4-1

    Auf 2.5.4-1 aktualisieren

  • openexr Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.5.4-1

    Auf 2.5.4-1 aktualisieren

  • openexr Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.5.4-1

    Auf 2.5.4-1 aktualisieren

  • openexr Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 2.2.0-1ubuntu3
    • 2.2.0-7ubuntu1
    • 2.2.0-9ubuntu1
    • 2.2.0-10ubuntu2
    • 2.2.0-10ubuntu2.1
    • 2.2.0-10ubuntu2.2
    • 2.2.0-10ubuntu2.3
    • 2.2.0-10ubuntu2.4
    • 2.2.0-10ubuntu2.6
    • 2.2.0-10ubuntu2.6+esm1
    • 2.2.0-10ubuntu2.6+esm2
    • 2.2.0-10ubuntu2.6+esm3
    • 2.2.0-10ubuntu2.6+esm4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • openexr Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 2.2.0-11ubuntu1
    • 2.2.0-11.1ubuntu1
    • 2.2.0-11.1ubuntu1.1
    • 2.2.0-11.1ubuntu1.2
    • 2.2.0-11.1ubuntu1.3
    • 2.2.0-11.1ubuntu1.4
    • 2.2.0-11.1ubuntu1.6
    • 2.2.0-11.1ubuntu1.7
    • 2.2.0-11.1ubuntu1.8
    • 2.2.0-11.1ubuntu1.9
    • 2.2.0-11.1ubuntu1.9+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • openexr Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 2.2.1-4.1ubuntu1
    • 2.3.0-6
    • 2.3.0-6build1
    • 2.3.0-6ubuntu0.1
    • 2.3.0-6ubuntu0.2
    • 2.3.0-6ubuntu0.3
    • 2.3.0-6ubuntu0.5
    • 2.3.0-6ubuntu0.5+esm1
    • 2.3.0-6ubuntu0.5+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →