p PatchFirst

CVE-2021-21290

CVE-2021-21290 · Local Information Disclosure Vulnerability in Netty on Unix-Like systems due temporary files

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.

Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In Netty before version 4.1.59.Final there is a vulnerability on Unix-like systems involving an insecure temp file. When netty's multipart decoders are used local information disclosure can occur via the local system temporary directory if temporary storing uploads on the disk is enabled. On unix-like systems, the temporary directory is shared between all user. As such, writing to this directory using APIs that do not explicitly set the file/directory permissions can lead to information disclosure. Of note, this does not impact modern MacOS Operating Systems. The method "File.createTempFile" on unix-like systems creates a random file, but, by default will create this file with the permissions "-rw-r--r--". Thus, if sensitive information is written to this file, other local users can read this information. This is the case in netty's "AbstractDiskHttpData" is vulnerable. This has been fixed in version 4.1.59.Final. As a workaround, one may specify your own "java.io.tmpdir" when you start the JVM or use "DefaultHttpDataFactory.setBaseDir(...)" to set the directory to something that is only readable by the current user.

CVSS 6.2 · Mittel · EPSS 1,8% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • netty

    Softwareversionen
    • < 4.1.59.Final: Betroffen

    Keine Korrektur veröffentlicht

  • netty Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.1.48-2

    Auf 1:4.1.48-2 aktualisieren

  • netty Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.1.48-2

    Auf 1:4.1.48-2 aktualisieren

  • netty Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.1.48-2

    Auf 1:4.1.48-2 aktualisieren

  • netty Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 1:3.2.6.Final-2
    • 1:3.2.6.Final-2+deb8u2build0.14.04.1~esm1
    • 1:3.2.6.Final-2+deb8u2ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • netty Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1:3.2.6.Final-2
    • 1:4.0.32-1
    • 1:4.0.33-1
    • 1:4.0.34-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.0.34-1ubuntu0.1~esm1

    Auf 1:4.0.34-1ubuntu0.1~esm1 aktualisieren

  • netty Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1:4.1.7-4
    • 1:4.1.7-4ubuntu0.1~esm1
    • 1:4.1.7-4ubuntu0.1
    • 1:4.1.7-4ubuntu0.1+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.1.7-4ubuntu0.1+esm2

    Auf 1:4.1.7-4ubuntu0.1+esm2 aktualisieren

  • netty Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 1:4.1.33-1
    • 1:4.1.33-2
    • 1:4.1.33-3
    • 1:4.1.45-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.1.45-1ubuntu0.1~esm1

    Auf 1:4.1.45-1ubuntu0.1~esm1 aktualisieren

  • netty Ubuntu:22.04:LTS

    Softwareversionen
    • 1:4.1.48-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.1.48-4+deb11u1build0.22.04.1

    Auf 1:4.1.48-4+deb11u1build0.22.04.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →