CVE-2021-21381
CVE-2021-21381 · Sandbox escape via special tokens in .desktop file
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Flatpak is a system for building, distributing, and running sandboxed desktop applications on Linux. In Flatpack since version 0.9.4 and before version 1.10.2 has a vulnerability in the "file forwarding" feature which can be used by an attacker to gain access to files that would not ordinarily be allowed by the app's permissions. By putting the special tokens `@@` and/or `@@u` in the Exec field of a Flatpak app's .desktop file, a malicious app publisher can trick flatpak into behaving as though the user had chosen to open a target file with their Flatpak app, which automatically makes that file available to the Flatpak app. This is fixed in version 1.10.2. A minimal solution is the first commit "`Disallow @@ and @@U usage in desktop files`". The follow-up commits "`dir: Reserve the whole @@ prefix`" and "`dir: Refuse to export .desktop files with suspicious uses of @@ tokens`" are recommended, but not strictly required. As a workaround, avoid installing Flatpak apps from untrusted sources, or check the contents of the exported `.desktop` files in `exports/share/applications/*.desktop` (typically `~/.local/share/flatpak/exports/share/applications/*.desktop` and `/var/lib/flatpak/exports/share/applications/*.desktop`) to make sure that literal filenames do not follow `@@` or `@@u`.
CVSS 7.1 · Hoch · EPSS 1,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
flatpak
- Softwareversionen
- >= 0.9.4, < 1.10.2: Betroffen
Keine Korrektur veröffentlicht
flatpak Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.10.1-4
Auf 1.10.1-4 aktualisieren
flatpak Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.10.1-4
Auf 1.10.1-4 aktualisieren
flatpak Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.10.1-4
Auf 1.10.1-4 aktualisieren
flatpak Ubuntu:18.04:LTS
- Softwareversionen
- 0.8.7-5
- 0.10.0-1
- 0.10.0-2
- 0.10.1-1
- 0.10.2-1
- 0.10.2.1-1
- 0.10.2.1-2
- 0.10.3-1
- 0.11.1-0ubuntu1
- 0.11.3-2
- 0.11.3-3
- 0.11.7-0ubuntu0.1
- 1.0.1-0ubuntu0.1
- 1.0.6-0ubuntu0.1
- 1.0.7-0ubuntu0.18.04.1
- 1.0.8-0ubuntu0.18.04.1
- 1.0.9-0ubuntu0.1
- 1.0.9-0ubuntu0.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.0.9-0ubuntu0.3
Auf 1.0.9-0ubuntu0.3 aktualisieren
flatpak Ubuntu:20.04:LTS
- Softwareversionen
- 1.4.3-1
- 1.6.0-1
- 1.6.1-1
- 1.6.2-1
- 1.6.3-1
- 1.6.5-0ubuntu0.1
- 1.6.5-0ubuntu0.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.5-0ubuntu0.3
Auf 1.6.5-0ubuntu0.3 aktualisieren
Originalquellen
- https://github.com/flatpak/flatpak/security/advisories/GHSA-xgh4-387p-hqpp
- https://github.com/flatpak/flatpak/pull/4156
- https://github.com/flatpak/flatpak/commit/8279c5818425b6812523e3805bbe242fb6a5d961
- https://github.com/flatpak/flatpak/commit/a7401e638bf0c03102039e216ab1081922f140ae
- https://github.com/flatpak/flatpak/commit/eb7946bb6248923d8c90fe9b84425fef97ae580d
- https://github.com/flatpak/flatpak/releases/tag/1.10.2
- https://www.debian.org/security/2021/dsa-4868
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WXNVFOIB6ZP4DGOVKAM25T6OIEP3YLGV/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2MXXLXC2DPJ45HSMTI5MZYHMYEGQN6AA/
- https://security.gentoo.org/glsa/202312-12
- https://nvd.nist.gov/vuln/detail/CVE-2021-21381