p PatchFirst

CVE-2021-22903

CVE-2021-22903

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

The actionpack ruby gem before 6.1.3.2 suffers from a possible open redirect vulnerability. Specially crafted Host headers in combination with certain "allowed host" formats can cause the Host Authorization middleware in Action Pack to redirect users to a malicious website. This is similar to CVE-2021-22881. Strings in config.hosts that do not have a leading dot are converted to regular expressions without proper escaping. This causes, for example, `config.hosts << "sub.example.com"` to permit a request with a Host header value of `sub-example.com`.

CVSS 6.1 · Mittel · EPSS 1,2%

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • https://github.com/rails/rails

    Softwareversionen
    • Fixed in 6.1.3.2: Betroffen

    Keine Korrektur veröffentlicht

  • rails Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 2:4.1.10-1
    • 2:4.2.5-1
    • 2:4.2.5.1-1
    • 2:4.2.5.2-2
    • 2:4.2.6-1
    • 2:4.2.6-1ubuntu0.1~esm1
    • 2:4.2.6-1ubuntu0.1~esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rails Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 2:4.2.9-2
    • 2:4.2.9-4
    • 2:4.2.10-0ubuntu4
    • 2:4.2.10-0ubuntu4+esm1
    • 2:4.2.10-0ubuntu4+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rails Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 2:5.2.2.1+dfsg-1ubuntu1
    • 2:5.2.3+dfsg-3
    • 2:5.2.3+dfsg-3ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rails Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 2:6.0.3.7+dfsg-2
    • 2:6.1.4.1+dfsg-8ubuntu2
    • 2:6.1.4.1+dfsg-8ubuntu2+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rails Ubuntu:24.04:LTS

    Softwareversionen
    • 2:6.1.7.3+dfsg-2build1
    • 2:6.1.7.3+dfsg-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rails Ubuntu:25.10

    Softwareversionen
    • 2:6.1.7.3+dfsg-7
    • 2:7.2.2.1+dfsg-7
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rails Ubuntu:26.10

    Softwareversionen
    • 2:7.2.3+dfsg-2
    • 2:7.2.3.2+dfsg-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rails Ubuntu:26.04:LTS

    Softwareversionen
    • 2:7.2.2.1+dfsg-7
    • 2:7.2.2.2+dfsg-2
    • 2:7.2.3+dfsg-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →