p PatchFirst

CVE-2021-22904

CVE-2021-22904

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

The actionpack ruby gem before 6.1.3.2, 6.0.3.7, 5.2.4.6, 5.2.6 suffers from a possible denial of service vulnerability in the Token Authentication logic in Action Controller due to a too permissive regular expression. Impacted code uses `authenticate_or_request_with_http_token` or `authenticate_with_http_token` for request authentication.

CVSS 7.5 · Hoch · EPSS 4,9% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • https://github.com/rails/rails

    Softwareversionen
    • Fixed in 6.1.3.2, 6.0.3.7, 5.2.4.6, 5.2.6: Betroffen

    Keine Korrektur veröffentlicht

  • rails Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2:6.0.3.7+dfsg-1

    Auf 2:6.0.3.7+dfsg-1 aktualisieren

  • rails Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2:6.0.3.7+dfsg-1

    Auf 2:6.0.3.7+dfsg-1 aktualisieren

  • rails Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2:6.0.3.7+dfsg-1

    Auf 2:6.0.3.7+dfsg-1 aktualisieren

  • rails Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 2:4.1.10-1
    • 2:4.2.5-1
    • 2:4.2.5.1-1
    • 2:4.2.5.2-2
    • 2:4.2.6-1
    • 2:4.2.6-1ubuntu0.1~esm1
    • 2:4.2.6-1ubuntu0.1~esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rails Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 2:4.2.9-2
    • 2:4.2.9-4
    • 2:4.2.10-0ubuntu4
    • 2:4.2.10-0ubuntu4+esm1
    • 2:4.2.10-0ubuntu4+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rails Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 2:5.2.2.1+dfsg-1ubuntu1
    • 2:5.2.3+dfsg-3
    • 2:5.2.3+dfsg-3ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rails Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 2:6.0.3.7+dfsg-2
    • 2:6.1.4.1+dfsg-8ubuntu2
    • 2:6.1.4.1+dfsg-8ubuntu2+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rails Ubuntu:24.04:LTS

    Softwareversionen
    • 2:6.1.7.3+dfsg-2build1
    • 2:6.1.7.3+dfsg-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rails Ubuntu:25.10

    Softwareversionen
    • 2:6.1.7.3+dfsg-7
    • 2:7.2.2.1+dfsg-7
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rails Ubuntu:26.10

    Softwareversionen
    • 2:7.2.3+dfsg-2
    • 2:7.2.3.2+dfsg-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rails Ubuntu:26.04:LTS

    Softwareversionen
    • 2:7.2.2.1+dfsg-7
    • 2:7.2.2.2+dfsg-2
    • 2:7.2.3+dfsg-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →