CVE-2021-29458
CVE-2021-29458 · Out-of-bounds read in Exiv2::Internal::CrwMap::encode
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An out-of-bounds read was found in Exiv2 versions v0.27.3 and earlier. The out-of-bounds read is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service by crashing Exiv2, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as insert. The bug is fixed in version v0.27.4.
CVSS 5.5 · Mittel · EPSS 1,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
exiv2
- Softwareversionen
- < 0.27.4: Betroffen
Keine Korrektur veröffentlicht
exiv2 Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.27.5-1
Auf 0.27.5-1 aktualisieren
exiv2 Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.27.5-1
Auf 0.27.5-1 aktualisieren
exiv2 Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.27.5-1
Auf 0.27.5-1 aktualisieren
exiv2 Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 0.25-1ubuntu1
- 0.25-2.1
- 0.25-2.1ubuntu16.04.1
- 0.25-2.1ubuntu16.04.2
- 0.25-2.1ubuntu16.04.3
- 0.25-2.1ubuntu16.04.4
- 0.25-2.1ubuntu16.04.5
- 0.25-2.1ubuntu16.04.6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.25-2.1ubuntu16.04.7+esm1
Auf 0.25-2.1ubuntu16.04.7+esm1 aktualisieren
exiv2 Ubuntu:18.04:LTS
- Softwareversionen
- 0.25-3.1
- 0.25-3.1ubuntu0.18.04.1
- 0.25-3.1ubuntu0.18.04.2
- 0.25-3.1ubuntu0.18.04.3
- 0.25-3.1ubuntu0.18.04.4
- 0.25-3.1ubuntu0.18.04.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.25-3.1ubuntu0.18.04.7
Auf 0.25-3.1ubuntu0.18.04.7 aktualisieren
exiv2 Ubuntu:20.04:LTS
- Softwareversionen
- 0.25-4ubuntu2
- 0.25-4ubuntu3
- 0.27.2-8ubuntu2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.27.2-8ubuntu2.2
Auf 0.27.2-8ubuntu2.2 aktualisieren
Originalquellen
- https://github.com/Exiv2/exiv2/issues/1530
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-57jj-75fm-9rq5
- https://github.com/Exiv2/exiv2/pull/1536
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2XQT5F5IINTDYDAFGVGQZ7PMMLG7I5ZZ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/P2A5GMJEXQ5Q76JK6F6VKK5JYCLVFGKN/
- https://lists.debian.org/debian-lts-announce/2023/01/msg00004.html
- https://security.gentoo.org/glsa/202312-06
- https://nvd.nist.gov/vuln/detail/CVE-2021-29458