CVE-2021-32715
CVE-2021-32715 · Lenient Parsing of Content-Length Header When Prefixed with Plus Sign
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
hyper is an HTTP library for rust. hyper's HTTP/1 server code had a flaw that incorrectly parses and accepts requests with a `Content-Length` header with a prefixed plus sign, when it should have been rejected as illegal. This combined with an upstream HTTP proxy that doesn't parse such `Content-Length` headers, but forwards them, can result in "request smuggling" or "desync attacks". The flaw exists in all prior versions of hyper prior to 0.14.10, if built with `rustc` v1.5.0 or newer. The vulnerability is patched in hyper version 0.14.10. Two workarounds exist: One may reject requests manually that contain a plus sign prefix in the `Content-Length` header or ensure any upstream proxy handles `Content-Length` headers with a plus sign prefix.
CVSS 3.1 · Niedrig · EPSS 1,1% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
hyper
- Softwareversionen
- < 0.14.10: Betroffen
Keine Korrektur veröffentlicht
rust-hyper Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.14.19-1
Auf 0.14.19-1 aktualisieren
rust-hyper Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.14.19-1
Auf 0.14.19-1 aktualisieren
rust-hyper Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.14.19-1
Auf 0.14.19-1 aktualisieren
rust-hyper Ubuntu:20.04:LTS
- Softwareversionen
- 0.12.35-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht