CVE-2021-32760
CVE-2021-32760 · Archive package allows chmod of file outside of unpack target directory
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
containerd is a container runtime. A bug was found in containerd versions prior to 1.4.8 and 1.5.4 where pulling and extracting a specially-crafted container image can result in Unix file permission changes for existing files in the host’s filesystem. Changes to file permissions can deny access to the expected owner of the file, widen access to others, or set extended bits like setuid, setgid, and sticky. This bug does not directly allow files to be read, modified, or executed without an additional cooperating process. This bug has been fixed in containerd 1.5.4 and 1.4.8. As a workaround, ensure that users only pull images from trusted sources. Linux security modules (LSMs) like SELinux and AppArmor can limit the files potentially affected by this bug through policies and profiles that prevent containerd from interacting with specific files.
CVSS 5.0 · Mittel · EPSS 1,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · containers
Betroffene Produkte und Versionen
containerd
- Softwareversionen
- <= 1.4.7: Betroffen
- >= 1.5.0, <= 1.5.3: Betroffen
Keine Korrektur veröffentlicht
containerd Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.4.5~ds1-2
Auf 1.4.5~ds1-2 aktualisieren
containerd Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.4.5~ds1-2
Auf 1.4.5~ds1-2 aktualisieren
containerd Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.4.5~ds1-2
Auf 1.4.5~ds1-2 aktualisieren
containerd Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 0.2.1-0ubuntu4~16.04
- 0.2.3-0ubuntu1~16.04
- 0.2.5-0ubuntu1~16.04.1
- 1.2.6-0ubuntu1~16.04.2
- 1.2.6-0ubuntu1~16.04.3
- 1.2.6-0ubuntu1~16.04.4
- 1.2.6-0ubuntu1~16.04.5
- 1.2.6-0ubuntu1~16.04.6
- 1.2.6-0ubuntu1~16.04.6+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.2.6-0ubuntu1~16.04.6+esm2
Auf 1.2.6-0ubuntu1~16.04.6+esm2 aktualisieren
containerd Ubuntu:18.04:LTS
- Softwareversionen
- 0.2.5-0ubuntu2
- 1.2.6-0ubuntu1~18.04.1
- 1.2.6-0ubuntu1~18.04.2
- 1.3.3-0ubuntu1~18.04.1
- 1.3.3-0ubuntu1~18.04.2
- 1.3.3-0ubuntu1~18.04.3
- 1.3.3-0ubuntu1~18.04.4
- 1.4.4-0ubuntu1~18.04.2
- 1.5.2-0ubuntu1~18.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.5.2-0ubuntu1~18.04.2
Auf 1.5.2-0ubuntu1~18.04.2 aktualisieren
containerd Ubuntu:20.04:LTS
- Softwareversionen
- 1.2.10-0ubuntu1
- 1.3.2-0ubuntu1
- 1.3.3-0ubuntu1
- 1.3.3-0ubuntu2
- 1.3.3-0ubuntu2.1
- 1.3.3-0ubuntu2.2
- 1.3.3-0ubuntu2.3
- 1.4.4-0ubuntu1~20.04.2
- 1.5.2-0ubuntu1~20.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.5.2-0ubuntu1~20.04.2
Auf 1.5.2-0ubuntu1~20.04.2 aktualisieren
Originalquellen
- https://github.com/containerd/containerd/security/advisories/GHSA-c72p-9xmj-rx3w
- https://github.com/containerd/containerd/releases/tag/v1.4.8
- https://github.com/containerd/containerd/releases/tag/v1.5.4
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DDMNDPJJTP3J5GOEDB66F6MGXUTRG3Y3/
- https://security.gentoo.org/glsa/202401-31
- https://nvd.nist.gov/vuln/detail/CVE-2021-32760