CVE-2021-32815
CVE-2021-32815 · Denial of service due to assertion failure in crwimage_int.cpp
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. The assertion failure is triggered when Exiv2 is used to modify the metadata of a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when modifying the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as `fi`. ### Patches The bug is fixed in version v0.27.5. ### References Regression test and bug fix: #1739 ### For more information Please see our [security policy](https://github.com/Exiv2/exiv2/security/policy) for information about Exiv2 security.
CVSS 5.5 · Mittel · EPSS 1,1% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
exiv2
- Softwareversionen
- < 0.27.5: Betroffen
Keine Korrektur veröffentlicht
exiv2 Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.27.5-1
Auf 0.27.5-1 aktualisieren
exiv2 Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.27.5-1
Auf 0.27.5-1 aktualisieren
exiv2 Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.27.5-1
Auf 0.27.5-1 aktualisieren
exiv2 Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 0.25-1ubuntu1
- 0.25-2.1
- 0.25-2.1ubuntu16.04.1
- 0.25-2.1ubuntu16.04.2
- 0.25-2.1ubuntu16.04.3
- 0.25-2.1ubuntu16.04.4
- 0.25-2.1ubuntu16.04.5
- 0.25-2.1ubuntu16.04.6
- 0.25-2.1ubuntu16.04.7+esm1
- 0.25-2.1ubuntu16.04.7+esm2
- 0.25-2.1ubuntu16.04.7+esm3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.25-2.1ubuntu16.04.7+esm4
Auf 0.25-2.1ubuntu16.04.7+esm4 aktualisieren
exiv2 Ubuntu:18.04:LTS
- Softwareversionen
- 0.25-3.1
- 0.25-3.1ubuntu0.18.04.1
- 0.25-3.1ubuntu0.18.04.2
- 0.25-3.1ubuntu0.18.04.3
- 0.25-3.1ubuntu0.18.04.4
- 0.25-3.1ubuntu0.18.04.5
- 0.25-3.1ubuntu0.18.04.7
- 0.25-3.1ubuntu0.18.04.9
- 0.25-3.1ubuntu0.18.04.10
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.25-3.1ubuntu0.18.04.11
Auf 0.25-3.1ubuntu0.18.04.11 aktualisieren
exiv2 Ubuntu:20.04:LTS
- Softwareversionen
- 0.25-4ubuntu2
- 0.25-4ubuntu3
- 0.27.2-8ubuntu2
- 0.27.2-8ubuntu2.2
- 0.27.2-8ubuntu2.4
- 0.27.2-8ubuntu2.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.27.2-8ubuntu2.6
Auf 0.27.2-8ubuntu2.6 aktualisieren
exiv2 Ubuntu:22.04:LTS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.27.3-3ubuntu4
Auf 0.27.3-3ubuntu4 aktualisieren
Originalquellen
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-mv9g-fxh2-m49m
- https://github.com/Exiv2/exiv2/pull/1739
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FMDT4PJB7P43WSOM3TRQIY3J33BAFVVE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UYGDELIFFJWKUU7SO3QATCIXCZJERGAC/
- https://lists.debian.org/debian-lts-announce/2023/01/msg00004.html
- https://security.gentoo.org/glsa/202312-06
- https://nvd.nist.gov/vuln/detail/CVE-2021-32815