p PatchFirst

CVE-2021-35938

CVE-2021-35938

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A symbolic link issue was found in rpm. It occurs when rpm sets the desired permissions and credentials after installing a file. A local unprivileged user could use this flaw to exchange the original file with a symbolic link to a security-critical file and escalate their privileges on the system. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

CVSS 6.7 · Mittel · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • rpm

    Softwareversionen
    • Fixed in rpm v4.18.0: Betroffen

    Keine Korrektur veröffentlicht

  • rpm Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.18.0+dfsg-1

    Auf 4.18.0+dfsg-1 aktualisieren

  • rpm Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.18.0+dfsg-1

    Auf 4.18.0+dfsg-1 aktualisieren

  • rpm Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.18.0+dfsg-1

    Auf 4.18.0+dfsg-1 aktualisieren

  • rpm Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 4.11.1-2
    • 4.11.1-3
    • 4.11.1-3ubuntu0.1
    • 4.11.1-3ubuntu0.1+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rpm Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 4.12.0.1+dfsg1-3build2
    • 4.12.0.1+dfsg1-3build3
    • 4.12.0.1+dfsg1-3ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rpm Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 4.12.0.2+dfsg1-2build2
    • 4.14.0+dfsg1-2
    • 4.14.1+dfsg1-2
    • 4.14.1+dfsg1-2ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rpm Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 4.14.2.1+dfsg1-1
    • 4.14.2.1+dfsg1-1build1
    • 4.14.2.1+dfsg1-1build2
    • 4.14.2.1+dfsg1-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rpm Ubuntu:22.04:LTS

    Softwareversionen
    • 4.16.1.2+dfsg1-3ubuntu1
    • 4.16.1.2+dfsg1-3ubuntu3
    • 4.17.0+dfsg1-1
    • 4.17.0+dfsg1-3
    • 4.17.0+dfsg1-4
    • 4.17.0+dfsg1-4build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rpm Ubuntu:24.04:LTS

    Softwareversionen
    • 4.18.0+dfsg-1build1
    • 4.18.0+dfsg-1build2
    • 4.18.2+dfsg-1
    • 4.18.2+dfsg-2
    • 4.18.2+dfsg-2.1build1
    • 4.18.2+dfsg-2.1build2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rpm Ubuntu:25.10

    Softwareversionen
    • 4.20.1+dfsg-1
    • 4.20.1+dfsg-2
    • 4.20.1+dfsg-2build1
    • 4.20.1+dfsg-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rpm Ubuntu:26.10

    Softwareversionen
    • 6.0.1-1build1
    • 6.1.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rpm Ubuntu:26.04:LTS

    Softwareversionen
    • 4.20.1+dfsg-3
    • 6.0.0-2
    • 6.0.1-1
    • 6.0.1-1build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →