CVE-2021-3631
CVE-2021-3631
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
A flaw was found in libvirt while it generates SELinux MCS category pairs for VMs' dynamic labels. This flaw allows one exploited guest to access files labeled for another guest, resulting in the breaking out of sVirt confinement. The highest threat from this vulnerability is to confidentiality and integrity.
CVSS 6.3 · Mittel · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
libvirt
- Softwareversionen
- Fixed-In - libvirt v7.5.0: Betroffen
Keine Korrektur veröffentlicht
libvirt Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.6.0-1
Auf 7.6.0-1 aktualisieren
libvirt Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.6.0-1
Auf 7.6.0-1 aktualisieren
libvirt Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.6.0-1
Auf 7.6.0-1 aktualisieren
libvirt Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 1.1.1-0ubuntu8
- 1.1.1-0ubuntu9
- 1.1.4-0ubuntu2
- 1.1.4-0ubuntu3
- 1.1.4-0ubuntu4
- 1.1.4-0ubuntu5
- 1.2.0-0ubuntu1
- 1.2.0-0ubuntu2
- 1.2.0-0ubuntu3
- 1.2.1-0ubuntu1
- 1.2.1-0ubuntu2
- 1.2.1-0ubuntu3
- 1.2.1-0ubuntu4
- 1.2.1-0ubuntu5
- 1.2.1-0ubuntu7
- 1.2.1-0ubuntu8
- 1.2.1-0ubuntu9
- 1.2.1-0ubuntu10
- 1.2.2-0ubuntu1
- 1.2.2-0ubuntu2
- 1.2.2-0ubuntu3
- 1.2.2-0ubuntu4
- 1.2.2-0ubuntu5
- 1.2.2-0ubuntu6
- 1.2.2-0ubuntu7
- 1.2.2-0ubuntu8
- 1.2.2-0ubuntu9
- 1.2.2-0ubuntu10
- 1.2.2-0ubuntu11
- 1.2.2-0ubuntu12
- 1.2.2-0ubuntu13
- 1.2.2-0ubuntu13.1
- 1.2.2-0ubuntu13.1.1
- 1.2.2-0ubuntu13.1.2
- 1.2.2-0ubuntu13.1.4
- 1.2.2-0ubuntu13.1.5
- 1.2.2-0ubuntu13.1.6
- 1.2.2-0ubuntu13.1.7
- 1.2.2-0ubuntu13.1.8
- 1.2.2-0ubuntu13.1.9
- 1.2.2-0ubuntu13.1.10
- 1.2.2-0ubuntu13.1.12
- 1.2.2-0ubuntu13.1.14
- 1.2.2-0ubuntu13.1.16
- 1.2.2-0ubuntu13.1.17
- 1.2.2-0ubuntu13.1.20
- 1.2.2-0ubuntu13.1.21
- 1.2.2-0ubuntu13.1.22
- 1.2.2-0ubuntu13.1.23
- 1.2.2-0ubuntu13.1.25
- 1.2.2-0ubuntu13.1.26
- 1.2.2-0ubuntu13.1.27
- 1.2.2-0ubuntu13.1.28
- 1.2.2-0ubuntu13.1.28+esm1
- 1.2.2-0ubuntu13.1.28+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libvirt Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1.2.16-2ubuntu11
- 1.2.16-2ubuntu12
- 1.2.16-2ubuntu13
- 1.2.16-2ubuntu14
- 1.2.21-2ubuntu1
- 1.2.21-2ubuntu3
- 1.2.21-2ubuntu4
- 1.2.21-2ubuntu5
- 1.2.21-2ubuntu7
- 1.2.21-2ubuntu8
- 1.2.21-2ubuntu9
- 1.2.21-2ubuntu10
- 1.3.1-1ubuntu1
- 1.3.1-1ubuntu2
- 1.3.1-1ubuntu3
- 1.3.1-1ubuntu4
- 1.3.1-1ubuntu6
- 1.3.1-1ubuntu9
- 1.3.1-1ubuntu10
- 1.3.1-1ubuntu10.1
- 1.3.1-1ubuntu10.2
- 1.3.1-1ubuntu10.3
- 1.3.1-1ubuntu10.5
- 1.3.1-1ubuntu10.6
- 1.3.1-1ubuntu10.7
- 1.3.1-1ubuntu10.8
- 1.3.1-1ubuntu10.10
- 1.3.1-1ubuntu10.11
- 1.3.1-1ubuntu10.12
- 1.3.1-1ubuntu10.13
- 1.3.1-1ubuntu10.14
- 1.3.1-1ubuntu10.15
- 1.3.1-1ubuntu10.17
- 1.3.1-1ubuntu10.18
- 1.3.1-1ubuntu10.19
- 1.3.1-1ubuntu10.21
- 1.3.1-1ubuntu10.22
- 1.3.1-1ubuntu10.23
- 1.3.1-1ubuntu10.24
- 1.3.1-1ubuntu10.25
- 1.3.1-1ubuntu10.26
- 1.3.1-1ubuntu10.27
- 1.3.1-1ubuntu10.29
- 1.3.1-1ubuntu10.30
- 1.3.1-1ubuntu10.31
- 1.3.1-1ubuntu10.31+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libvirt Ubuntu:18.04:LTS
- Softwareversionen
- 3.6.0-1ubuntu5
- 3.6.0-1ubuntu6
- 4.0.0-1ubuntu1
- 4.0.0-1ubuntu2
- 4.0.0-1ubuntu3
- 4.0.0-1ubuntu4
- 4.0.0-1ubuntu5
- 4.0.0-1ubuntu6
- 4.0.0-1ubuntu7
- 4.0.0-1ubuntu8
- 4.0.0-1ubuntu8.1
- 4.0.0-1ubuntu8.2
- 4.0.0-1ubuntu8.3
- 4.0.0-1ubuntu8.4
- 4.0.0-1ubuntu8.5
- 4.0.0-1ubuntu8.6
- 4.0.0-1ubuntu8.7
- 4.0.0-1ubuntu8.8
- 4.0.0-1ubuntu8.9
- 4.0.0-1ubuntu8.10
- 4.0.0-1ubuntu8.11
- 4.0.0-1ubuntu8.12
- 4.0.0-1ubuntu8.13
- 4.0.0-1ubuntu8.14
- 4.0.0-1ubuntu8.15
- 4.0.0-1ubuntu8.16
- 4.0.0-1ubuntu8.17
- 4.0.0-1ubuntu8.19
- 4.0.0-1ubuntu8.20
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.0.0-1ubuntu8.21
Auf 4.0.0-1ubuntu8.21 aktualisieren
libvirt Ubuntu:20.04:LTS
- Softwareversionen
- 5.4.0-0ubuntu5
- 6.0.0-0ubuntu1
- 6.0.0-0ubuntu2
- 6.0.0-0ubuntu3
- 6.0.0-0ubuntu4
- 6.0.0-0ubuntu5
- 6.0.0-0ubuntu6
- 6.0.0-0ubuntu7
- 6.0.0-0ubuntu8
- 6.0.0-0ubuntu8.1
- 6.0.0-0ubuntu8.2
- 6.0.0-0ubuntu8.3
- 6.0.0-0ubuntu8.4
- 6.0.0-0ubuntu8.5
- 6.0.0-0ubuntu8.7
- 6.0.0-0ubuntu8.8
- 6.0.0-0ubuntu8.9
- 6.0.0-0ubuntu8.10
- 6.0.0-0ubuntu8.11
- 6.0.0-0ubuntu8.12
- 6.0.0-0ubuntu8.13
- 6.0.0-0ubuntu8.14
- 6.0.0-0ubuntu8.15
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.0.0-0ubuntu8.16
Auf 6.0.0-0ubuntu8.16 aktualisieren
libvirt Ubuntu:22.04:LTS
- Softwareversionen
- 7.6.0-0ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.6.0-0ubuntu3
Auf 7.6.0-0ubuntu3 aktualisieren
Originalquellen
- https://bugzilla.redhat.com/show_bug.cgi?id=1977726
- https://gitlab.com/libvirt/libvirt/-/issues/153
- https://gitlab.com/libvirt/libvirt/-/commit/15073504dbb624d3f6c911e85557019d3620fdb2
- https://access.redhat.com/errata/RHSA-2021:3631
- https://security.netapp.com/advisory/ntap-20220331-0010/
- https://security.gentoo.org/glsa/202210-06
- https://lists.debian.org/debian-lts-announce/2024/04/msg00000.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-3631