CVE-2021-37616
CVE-2021-37616 · Null pointer dereference in Exiv2::Internal::resolveLens0x8ff
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. A null pointer dereference was found in Exiv2 versions v0.27.4 and earlier. The null pointer dereference is triggered when Exiv2 is used to print the metadata of a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when printing the interpreted (translated) data, which is a less frequently used Exiv2 operation that requires an extra command line option (`-p t` or `-P t`). The bug is fixed in version v0.27.5.
CVSS 5.5 · Mittel · EPSS 1,0% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
exiv2
- Softwareversionen
- <= 0.27.4: Betroffen
Keine Korrektur veröffentlicht
exiv2 Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.27.5-1
Auf 0.27.5-1 aktualisieren
exiv2 Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.27.5-1
Auf 0.27.5-1 aktualisieren
exiv2 Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.27.5-1
Auf 0.27.5-1 aktualisieren
exiv2 Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 0.25-1ubuntu1
- 0.25-2.1
- 0.25-2.1ubuntu16.04.1
- 0.25-2.1ubuntu16.04.2
- 0.25-2.1ubuntu16.04.3
- 0.25-2.1ubuntu16.04.4
- 0.25-2.1ubuntu16.04.5
- 0.25-2.1ubuntu16.04.6
- 0.25-2.1ubuntu16.04.7+esm1
- 0.25-2.1ubuntu16.04.7+esm2
- 0.25-2.1ubuntu16.04.7+esm3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.25-2.1ubuntu16.04.7+esm4
Auf 0.25-2.1ubuntu16.04.7+esm4 aktualisieren
exiv2 Ubuntu:20.04:LTS
- Softwareversionen
- 0.25-4ubuntu2
- 0.25-4ubuntu3
- 0.27.2-8ubuntu2
- 0.27.2-8ubuntu2.2
- 0.27.2-8ubuntu2.4
- 0.27.2-8ubuntu2.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.27.2-8ubuntu2.6
Auf 0.27.2-8ubuntu2.6 aktualisieren
exiv2 Ubuntu:22.04:LTS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.27.3-3ubuntu4
Auf 0.27.3-3ubuntu4 aktualisieren
Originalquellen
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-54f7-vvj7-545w
- https://github.com/Exiv2/exiv2/pull/1758
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FMDT4PJB7P43WSOM3TRQIY3J33BAFVVE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UYGDELIFFJWKUU7SO3QATCIXCZJERGAC/
- https://security.gentoo.org/glsa/202312-06
- https://nvd.nist.gov/vuln/detail/CVE-2021-37616