CVE-2021-3975
CVE-2021-3975
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
A use-after-free flaw was found in libvirt. The qemuMonitorUnregister() function in qemuProcessHandleMonitorEOF is called using multiple threads without being adequately protected by a monitor lock. This flaw could be triggered by the virConnectGetAllDomainStats API when the guest is shutting down. An unprivileged client with a read-only connection could use this flaw to perform a denial of service attack by causing the libvirt daemon to crash.
CVSS 6.5 · Mittel · EPSS 1,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
libvirt
- Softwareversionen
- Fixed in libvirt v7.1.0: Betroffen
Keine Korrektur veröffentlicht
libvirt Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.6.0-1
Auf 7.6.0-1 aktualisieren
libvirt Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.6.0-1
Auf 7.6.0-1 aktualisieren
libvirt Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.6.0-1
Auf 7.6.0-1 aktualisieren
libvirt Ubuntu:18.04:LTS
- Softwareversionen
- 3.6.0-1ubuntu5
- 3.6.0-1ubuntu6
- 4.0.0-1ubuntu1
- 4.0.0-1ubuntu2
- 4.0.0-1ubuntu3
- 4.0.0-1ubuntu4
- 4.0.0-1ubuntu5
- 4.0.0-1ubuntu6
- 4.0.0-1ubuntu7
- 4.0.0-1ubuntu8
- 4.0.0-1ubuntu8.1
- 4.0.0-1ubuntu8.2
- 4.0.0-1ubuntu8.3
- 4.0.0-1ubuntu8.4
- 4.0.0-1ubuntu8.5
- 4.0.0-1ubuntu8.6
- 4.0.0-1ubuntu8.7
- 4.0.0-1ubuntu8.8
- 4.0.0-1ubuntu8.9
- 4.0.0-1ubuntu8.10
- 4.0.0-1ubuntu8.11
- 4.0.0-1ubuntu8.12
- 4.0.0-1ubuntu8.13
- 4.0.0-1ubuntu8.14
- 4.0.0-1ubuntu8.15
- 4.0.0-1ubuntu8.16
- 4.0.0-1ubuntu8.17
- 4.0.0-1ubuntu8.19
- 4.0.0-1ubuntu8.20
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.0.0-1ubuntu8.21
Auf 4.0.0-1ubuntu8.21 aktualisieren
libvirt Ubuntu:20.04:LTS
- Softwareversionen
- 5.4.0-0ubuntu5
- 6.0.0-0ubuntu1
- 6.0.0-0ubuntu2
- 6.0.0-0ubuntu3
- 6.0.0-0ubuntu4
- 6.0.0-0ubuntu5
- 6.0.0-0ubuntu6
- 6.0.0-0ubuntu7
- 6.0.0-0ubuntu8
- 6.0.0-0ubuntu8.1
- 6.0.0-0ubuntu8.2
- 6.0.0-0ubuntu8.3
- 6.0.0-0ubuntu8.4
- 6.0.0-0ubuntu8.5
- 6.0.0-0ubuntu8.7
- 6.0.0-0ubuntu8.8
- 6.0.0-0ubuntu8.9
- 6.0.0-0ubuntu8.10
- 6.0.0-0ubuntu8.11
- 6.0.0-0ubuntu8.12
- 6.0.0-0ubuntu8.13
- 6.0.0-0ubuntu8.14
- 6.0.0-0ubuntu8.15
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.0.0-0ubuntu8.16
Auf 6.0.0-0ubuntu8.16 aktualisieren
libvirt Ubuntu:22.04:LTS
- Softwareversionen
- 7.6.0-0ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.6.0-0ubuntu3
Auf 7.6.0-0ubuntu3 aktualisieren
Originalquellen
- https://bugzilla.redhat.com/show_bug.cgi?id=2024326
- https://access.redhat.com/security/cve/CVE-2021-3975
- https://ubuntu.com/security/CVE-2021-3975
- https://github.com/libvirt/libvirt/commit/1ac703a7d0789e46833f4013a3876c2e3af18ec7
- https://security.netapp.com/advisory/ntap-20221201-0002/
- https://lists.debian.org/debian-lts-announce/2024/04/msg00000.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-3975