p PatchFirst

CVE-2021-41116

CVE-2021-41116 · Command injection in composer on Windows

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Composer is an open source dependency manager for the PHP language. In affected versions windows users running Composer to install untrusted dependencies are subject to command injection and should upgrade their composer version. Other OSs and WSL are not affected. The issue has been resolved in composer versions 1.10.23 and 2.1.9. There are no workarounds for this issue.

CVSS 8.2 · Hoch · EPSS 2,8% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · php

Betroffene Produkte und Versionen

  • composer

    Softwareversionen
    • < 1.10.23: Betroffen
    • >= 2.0, < 2.1.9: Betroffen

    Keine Korrektur veröffentlicht

  • composer/composer Packagist

    Softwareversionen
    • 1.0.0
    • 1.0.0-alpha1
    • 1.0.0-alpha10
    • 1.0.0-alpha11
    • 1.0.0-alpha2
    • 1.0.0-alpha3
    • 1.0.0-alpha4
    • 1.0.0-alpha5
    • 1.0.0-alpha6
    • 1.0.0-alpha7
    • 1.0.0-alpha8
    • 1.0.0-alpha9
    • 1.0.0-beta1
    • 1.0.0-beta2
    • 1.0.1
    • 1.0.2
    • 1.0.3
    • 1.1.0
    • 1.1.0-RC
    • 1.1.1
    • 1.1.2
    • 1.1.3
    • 1.10.0
    • 1.10.0-RC
    • 1.10.1
    • 1.10.10
    • 1.10.11
    • 1.10.12
    • 1.10.13
    • 1.10.14
    • 1.10.15
    • 1.10.16
    • 1.10.17
    • 1.10.18
    • 1.10.19
    • 1.10.2
    • 1.10.20
    • 1.10.21
    • 1.10.22
    • 1.10.3
    • 1.10.4
    • 1.10.5
    • 1.10.6
    • 1.10.7
    • 1.10.8
    • 1.10.9
    • 1.2.0
    • 1.2.0-RC
    • 1.2.1
    • 1.2.2
    • 1.2.3
    • 1.2.4
    • 1.3.0
    • 1.3.0-RC
    • 1.3.1
    • 1.3.2
    • 1.3.3
    • 1.4.0
    • 1.4.1
    • 1.4.2
    • 1.4.3
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 1.5.4
    • 1.5.5
    • 1.5.6
    • 1.6.0
    • 1.6.0-RC
    • 1.6.1
    • 1.6.2
    • 1.6.3
    • 1.6.4
    • 1.6.5
    • 1.7.0
    • 1.7.0-RC
    • 1.7.1
    • 1.7.2
    • 1.7.3
    • 1.8.0
    • 1.8.1
    • 1.8.2
    • 1.8.3
    • 1.8.4
    • 1.8.5
    • 1.8.6
    • 1.9.0
    • 1.9.1
    • 1.9.2
    • 1.9.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.10.23

    Auf 1.10.23 aktualisieren

  • composer/composer Packagist

    Softwareversionen
    • 2.0.0
    • 2.0.0-RC1
    • 2.0.0-RC2
    • 2.0.0-alpha1
    • 2.0.0-alpha2
    • 2.0.0-alpha3
    • 2.0.1
    • 2.0.10
    • 2.0.11
    • 2.0.12
    • 2.0.13
    • 2.0.14
    • 2.0.2
    • 2.0.3
    • 2.0.4
    • 2.0.5
    • 2.0.6
    • 2.0.7
    • 2.0.8
    • 2.0.9
    • 2.1.0
    • 2.1.0-RC1
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.1.5
    • 2.1.6
    • 2.1.7
    • 2.1.8
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.0.0-alpha1, < 2.1.9

    Auf 2.1.9 aktualisieren

  • composer Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1.0.0~alpha10+20150602-1
    • 1.0.0~alpha10+20150602-2
    • 1.0.0~alpha11-1
    • 1.0.0~alpha11-1ubuntu1
    • 1.0.0~alpha11-2
    • 1.0.0~alpha11-3
    • 1.0.0~beta1-1ubuntu1
    • 1.0.0~beta2-1
    • 1.0.0~beta2-1ubuntu0.1~esm1
    • 1.0.0~beta2-1ubuntu0.1~esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →