p PatchFirst

CVE-2021-41132

CVE-2021-41132 · Inconsistent input sanitisation leads to XSS vectors

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

OMERO.web provides a web based client and plugin infrastructure. In versions prior to 5.11.0, a variety of templates do not perform proper sanitization through HTML escaping. Due to the lack of sanitization and use of ``jQuery.html()``, there are a whole host of cross-site scripting possibilities with specially crafted input to a variety of fields. This issue is patched in version 5.11.0. There are no known workarounds aside from upgrading.

CVSS 9.8 · Kritisch · EPSS 1,0% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • omero-web

    Softwareversionen
    • < 5.11.0: Betroffen

    Keine Korrektur veröffentlicht

  • omero-web PyPI

    Softwareversionen
    • 5.10.0
    • 5.11.0rc1
    • 5.5.dev1
    • 5.5.dev2
    • 5.6.0
    • 5.6.1
    • 5.6.2
    • 5.6.3
    • 5.6.dev1
    • 5.6.dev2
    • 5.6.dev3
    • 5.6.dev4
    • 5.6.dev5
    • 5.6.dev6
    • 5.6.dev7
    • 5.7.0
    • 5.7.1
    • 5.8.0
    • 5.8.1
    • 5.9.0
    • 5.9.1
    • 5.9.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.11.0

    Auf 5.11.0 aktualisieren

  • omero-figure PyPI

    Softwareversionen
    • 2.0.0
    • 2.0.1
    • 3.0.0
    • 3.1.0
    • 3.1.1
    • 3.1.2
    • 3.2.0
    • 3.2.1
    • 4.0.0
    • 4.0.1
    • 4.0.2
    • 4.1.0
    • 4.2.0
    • 4.2.dev1
    • 4.3.0
    • 4.3.1
    • 4.3.2
    • 4.4.0
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.4.1

    Auf 4.4.1 aktualisieren

  • omero-web PyPI

    Softwareversionen
    • 5.10.0
    • 5.11.0rc1
    • 5.5.dev1
    • 5.5.dev2
    • 5.6.0
    • 5.6.1
    • 5.6.2
    • 5.6.3
    • 5.6.dev1
    • 5.6.dev2
    • 5.6.dev3
    • 5.6.dev4
    • 5.6.dev5
    • 5.6.dev6
    • 5.6.dev7
    • 5.7.0
    • 5.7.1
    • 5.8.0
    • 5.8.1
    • 5.9.0
    • 5.9.1
    • 5.9.2
    Betroffene Versionsbereiche
    • GIT: < 0168067accde5e635341b3c714b1d53ae92ba424
    • ECOSYSTEM: < 5.11.0

    Auf 5.11.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →