p PatchFirst

CVE-2021-41247

CVE-2021-41247 · incomplete logout in JupyterHub

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

JupyterHub is an open source multi-user server for Jupyter notebooks. In affected versions users who have multiple JupyterLab tabs open in the same browser session, may see incomplete logout from the single-user server, as fresh credentials (for the single-user server only, not the Hub) reinstated after logout, if another active JupyterLab session is open while the logout takes place. Upgrade to JupyterHub 1.5. For distributed deployments, it is jupyterhub in the _user_ environment that needs patching. There are no patches necessary in the Hub environment. The only workaround is to make sure that only one JupyterLab tab is open when you log out.

CVSS 3.5 · Niedrig · EPSS 0,8% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • jupyterhub

    Softwareversionen
    • >= 1.0.0, < 1.5.0 - jupyterhub (pip): Betroffen
    • < 1.2.0 - jupyterhub (helm): Betroffen

    Keine Korrektur veröffentlicht

  • jupyterhub Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.0.0+ds1-1

    Auf 2.0.0+ds1-1 aktualisieren

  • jupyterhub Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.0.0+ds1-1

    Auf 2.0.0+ds1-1 aktualisieren

  • jupyterhub Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.0.0+ds1-1

    Auf 2.0.0+ds1-1 aktualisieren

  • jupyterhub PyPI

    Softwareversionen
    • 1.0.0
    • 1.1.0
    • 1.1.0b1
    • 1.2.0
    • 1.2.0b1
    • 1.2.1
    • 1.2.2
    • 1.3.0
    • 1.4.0
    • 1.4.1
    • 1.4.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.0, < 1.5.0

    Auf 1.5.0 aktualisieren

  • jupyterhub PyPI

    Softwareversionen
    • 1.0.0
    • 1.1.0
    • 1.1.0b1
    • 1.2.0
    • 1.2.0b1
    • 1.2.1
    • 1.2.2
    • 1.3.0
    • 1.4.0
    • 1.4.1
    • 1.4.2
    Betroffene Versionsbereiche
    • GIT: < 5ac9e7f73a6e1020ffddc40321fc53336829fe27
    • ECOSYSTEM: ≥ 1.0.0, < 1.5.0

    Auf 1.5.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →