CVE-2021-41991
CVE-2021-41991
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
The in-memory certificate cache in strongSwan before 5.9.4 has a remote integer overflow upon receiving many requests with different certificates to fill the cache and later trigger the replacement of cache entries. The code attempts to select a less-often-used cache entry by means of a random number generator, but this is not done correctly. Remote code execution might be a slight possibility.
CVSS 7.5 · Hoch · EPSS 5,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
n/a
- Softwareversionen
- n/a: Betroffen
Keine Korrektur veröffentlicht
strongswan Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.9.4-1
Auf 5.9.4-1 aktualisieren
strongswan Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.9.4-1
Auf 5.9.4-1 aktualisieren
strongswan Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.9.4-1
Auf 5.9.4-1 aktualisieren
strongswan Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 4.6.4-9
- 5.1.0-2
- 5.1.0-3
- 5.1.1-0ubuntu1
- 5.1.1-0ubuntu2
- 5.1.1-0ubuntu3
- 5.1.1-0ubuntu4
- 5.1.1-0ubuntu5
- 5.1.1-0ubuntu7
- 5.1.1-0ubuntu14
- 5.1.1-0ubuntu17
- 5.1.2~dr3+git20130120-0ubuntu2
- 5.1.2~dr3+git20130120-0ubuntu3
- 5.1.2~rc1-0ubuntu3
- 5.1.2~rc1-0ubuntu4
- 5.1.2~rc2-0ubuntu2
- 5.1.2-0ubuntu1
- 5.1.2-0ubuntu2
- 5.1.2-0ubuntu2.2
- 5.1.2-0ubuntu2.3
- 5.1.2-0ubuntu2.4
- 5.1.2-0ubuntu2.5
- 5.1.2-0ubuntu2.6
- 5.1.2-0ubuntu2.7
- 5.1.2-0ubuntu2.8
- 5.1.2-0ubuntu2.10
- 5.1.2-0ubuntu2.11
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.1.2-0ubuntu2.11+esm1
Auf 5.1.2-0ubuntu2.11+esm1 aktualisieren
strongswan Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 5.1.2-0ubuntu6
- 5.1.2-0ubuntu7
- 5.1.2-0ubuntu8
- 5.3.5-1ubuntu1
- 5.3.5-1ubuntu2
- 5.3.5-1ubuntu3
- 5.3.5-1ubuntu3.1
- 5.3.5-1ubuntu3.2
- 5.3.5-1ubuntu3.3
- 5.3.5-1ubuntu3.4
- 5.3.5-1ubuntu3.5
- 5.3.5-1ubuntu3.7
- 5.3.5-1ubuntu3.8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.3.5-1ubuntu3.8+esm1
Auf 5.3.5-1ubuntu3.8+esm1 aktualisieren
strongswan Ubuntu:Pro:FIPS-updates:16.04:LTS
- Softwareversionen
- 5.3.5-1ubuntu3.fips.3.4.1
- 5.3.5-1ubuntu3.fips.3.4.2
- 5.3.5-1ubuntu3.fips.3.8.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.3.5-1ubuntu3.fips.3.8.2
Auf 5.3.5-1ubuntu3.fips.3.8.2 aktualisieren
strongswan Ubuntu:Pro:FIPS:16.04:LTS
- Softwareversionen
- 5.3.5-1ubuntu3.fips.3.1
- 5.3.5-1ubuntu3.fips.3.2
- 5.3.5-1ubuntu3.fips.3.3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
strongswan Ubuntu:18.04:LTS
- Softwareversionen
- 5.5.1-4ubuntu2
- 5.5.1-4ubuntu3
- 5.6.1-2ubuntu1
- 5.6.1-2ubuntu2
- 5.6.1-2ubuntu3
- 5.6.1-2ubuntu4
- 5.6.2-1ubuntu2
- 5.6.2-1ubuntu2.2
- 5.6.2-1ubuntu2.3
- 5.6.2-1ubuntu2.4
- 5.6.2-1ubuntu2.5
- 5.6.2-1ubuntu2.6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.6.2-1ubuntu2.7
Auf 5.6.2-1ubuntu2.7 aktualisieren
strongswan Ubuntu:Pro:FIPS-updates:18.04:LTS
- Softwareversionen
- 5.6.2-1ubuntu2.fips.2.5.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.6.2-1ubuntu2.fips.2.7.1
Auf 5.6.2-1ubuntu2.fips.2.7.1 aktualisieren
strongswan Ubuntu:Pro:FIPS:18.04:LTS
- Softwareversionen
- 5.6.2-1ubuntu2.fips.2.4.2
- 5.6.2-1ubuntu2.fips.2.5.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
strongswan Ubuntu:20.04:LTS
- Softwareversionen
- 5.7.2-1ubuntu3
- 5.8.1-1ubuntu1
- 5.8.2-1ubuntu1
- 5.8.2-1ubuntu2
- 5.8.2-1ubuntu3
- 5.8.2-1ubuntu3.1
- 5.8.2-1ubuntu3.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.8.2-1ubuntu3.3
Auf 5.8.2-1ubuntu3.3 aktualisieren
strongswan Ubuntu:Pro:FIPS-updates:20.04:LTS
- Softwareversionen
- 5.8.2-1ubuntu3.fips.3.1.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.8.2-1ubuntu3.fips.3.3.1
Auf 5.8.2-1ubuntu3.fips.3.3.1 aktualisieren
strongswan Ubuntu:Pro:FIPS:20.04:LTS
- Softwareversionen
- 5.8.2-1ubuntu3.fips.3.1.2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
strongswan Ubuntu:22.04:LTS
- Softwareversionen
- 5.9.1-1ubuntu3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.9.1-1ubuntu3.1
Auf 5.9.1-1ubuntu3.1 aktualisieren
Originalquellen
- https://github.com/strongswan/strongswan/releases/tag/5.9.4
- https://www.strongswan.org/blog/2021/10/18/strongswan-vulnerability-%28cve-2021-41991%29.html
- https://www.debian.org/security/2021/dsa-4989
- https://lists.debian.org/debian-lts-announce/2021/10/msg00014.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/5FJSATD2R2XHTG4P63GCMQ2N7EWKMME5/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WQSQ3BEC22NF4NCDZVCT4P3Q2ZIAJXGJ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/Y3TQ32JLJOBJDB2EJKSX2PBPB5NFG2D4/
- https://cert-portal.siemens.com/productcert/pdf/ssa-539476.pdf
- https://nvd.nist.gov/vuln/detail/CVE-2021-41991