CVE-2021-43797
CVE-2021-43797 · HTTP fails to validate against control chars in header names which may lead to HTTP request smuggling
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. Netty prior to version 4.1.71.Final skips control chars when they are present at the beginning / end of the header name. It should instead fail fast as these are not allowed by the spec and could lead to HTTP request smuggling. Failing to do the validation might cause netty to "sanitize" header names before it forward these to another remote system when used as proxy. This remote system can't see the invalid usage anymore, and therefore does not do the validation itself. Users should upgrade to version 4.1.71.Final.
CVSS 6.5 · Mittel · EPSS 2,9% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
netty
- Softwareversionen
- <= 4.1.7.0.Final: Betroffen
Keine Korrektur veröffentlicht
netty Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.1.48-6
Auf 1:4.1.48-6 aktualisieren
netty Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.1.48-6
Auf 1:4.1.48-6 aktualisieren
netty Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.1.48-6
Auf 1:4.1.48-6 aktualisieren
netty Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 1:3.2.6.Final-2
- 1:3.2.6.Final-2+deb8u2build0.14.04.1~esm1
- 1:3.2.6.Final-2+deb8u2ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
netty Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1:3.2.6.Final-2
- 1:4.0.32-1
- 1:4.0.33-1
- 1:4.0.34-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.0.34-1ubuntu0.1~esm1
Auf 1:4.0.34-1ubuntu0.1~esm1 aktualisieren
netty Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 1:4.1.7-4
- 1:4.1.7-4ubuntu0.1~esm1
- 1:4.1.7-4ubuntu0.1
- 1:4.1.7-4ubuntu0.1+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.1.7-4ubuntu0.1+esm2
Auf 1:4.1.7-4ubuntu0.1+esm2 aktualisieren
netty Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 1:4.1.33-1
- 1:4.1.33-2
- 1:4.1.33-3
- 1:4.1.45-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.1.45-1ubuntu0.1~esm1
Auf 1:4.1.45-1ubuntu0.1~esm1 aktualisieren
netty Ubuntu:22.04:LTS
- Softwareversionen
- 1:4.1.48-4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.1.48-4+deb11u1build0.22.04.1
Auf 1:4.1.48-4+deb11u1build0.22.04.1 aktualisieren
Originalquellen
- https://github.com/netty/netty/security/advisories/GHSA-wx5j-54mm-rqqq
- https://github.com/netty/netty/commit/07aa6b5938a8b6ed7a6586e066400e2643897323
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://security.netapp.com/advisory/ntap-20220107-0003/
- https://www.oracle.com/security-alerts/cpujul2022.html
- https://lists.debian.org/debian-lts-announce/2023/01/msg00008.html
- https://www.debian.org/security/2023/dsa-5316
- https://nvd.nist.gov/vuln/detail/CVE-2021-43797