CVE-2021-43861
CVE-2021-43861 · Incorrect sanitisation function leads to `XSS`
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Mermaid is a Javascript based diagramming and charting tool that uses Markdown-inspired text definitions and a renderer to create and modify complex diagrams. Prior to version 8.13.8, malicious diagrams can run javascript code at diagram readers' machines. Users should upgrade to version 8.13.8 to receive a patch. There are no known workarounds aside from upgrading.
CVSS 7.2 · Hoch · EPSS 0,9% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
mermaid
- Softwareversionen
- < 8.13.8: Betroffen
Keine Korrektur veröffentlicht
node-mermaid Debian:14
- Softwareversionen
- 8.11.0+ds+~cs29.13.22-1
- 8.13.2+ds+~cs30.13.21-1
- 8.13.2+ds+~cs30.13.21-1.1
- 8.13.3+ds+~cs26.13.21-1
- 8.13.3+ds+~cs26.13.21-2
- 8.7.0+ds+~cs27.17.17-1
- 8.7.0+ds+~cs27.17.17-2
- 8.7.0+ds+~cs27.17.17-2~bpo10+1
- 8.7.0+ds+~cs27.17.17-3
- 8.9.1+ds+~cs26.20.25-1
- 8.9.3+ds+~cs29.13.19-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.13.8+~cs10.4.16-1
Auf 8.13.8+~cs10.4.16-1 aktualisieren
mermaid npm
- Betroffene Versionsbereiche
- SEMVER: < 8.13.8
Auf 8.13.8 aktualisieren
node-mermaid Ubuntu:22.04:LTS
- Softwareversionen
- 8.7.0+ds+~cs27.17.17-3
- 8.13.3+ds+~cs26.13.21-1
- 8.13.3+ds+~cs26.13.21-2
- 8.13.8+~cs10.4.16-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-mermaid Ubuntu:26.10
- Softwareversionen
- 9.2.2+~2.0.0-1
- 9.2.2+~2.0.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht