CVE-2022-21681
CVE-2022-21681 · Exponential catastrophic backtracking (ReDoS) in marked
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Marked is a markdown parser and compiler. Prior to version 4.0.10, the regular expression `inline.reflinkSearch` may cause catastrophic backtracking against some strings and lead to a denial of service (DoS). Anyone who runs untrusted markdown through a vulnerable version of marked and does not use a worker with a time limit may be affected. This issue is patched in version 4.0.10. As a workaround, avoid running untrusted markdown through marked or run marked on a worker thread and set a reasonable time limit to prevent draining resources.
CVSS 7.5 · Hoch · EPSS 2,8% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
marked
- Softwareversionen
- < 4.0.10: Betroffen
Keine Korrektur veröffentlicht
node-marked Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.0.12+ds+~4.0.1-1
Auf 4.0.12+ds+~4.0.1-1 aktualisieren
node-marked Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.0.12+ds+~4.0.1-1
Auf 4.0.12+ds+~4.0.1-1 aktualisieren
node-marked Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.0.12+ds+~4.0.1-1
Auf 4.0.12+ds+~4.0.1-1 aktualisieren
marked npm
- Betroffene Versionsbereiche
- SEMVER: < 4.0.10
Auf 4.0.10 aktualisieren
node-marked Ubuntu:16.04:LTS
- Softwareversionen
- 0.3.2+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-marked Ubuntu:18.04:LTS
- Softwareversionen
- 0.3.6+dfsg-1
- 0.3.9+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-marked Ubuntu:20.04:LTS
- Softwareversionen
- 0.5.1+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-marked Ubuntu:22.04:LTS
- Softwareversionen
- 0.8.0+ds+repack-2
- 0.8.0+ds+repack-3
- 4.0.5+ds-5
- 4.0.9+ds+~4.0.1-2
- 4.0.12+ds+~4.0.1-1
- 4.0.12+ds+~4.0.1-2ubuntu1
- 4.0.12+ds+~4.0.1-2ubuntu2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-marked Ubuntu:24.04:LTS
- Softwareversionen
- 4.2.3+ds+~4.0.7-2ubuntu1
- 4.2.3+ds+~4.0.7-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-marked Ubuntu:25.10
- Softwareversionen
- 4.2.3+ds+~4.0.7-3
- 4.2.3+ds+~4.0.7-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-marked Ubuntu:26.10
- Softwareversionen
- 4.2.3+ds+~4.0.7-4
- 4.3.0+ds1+~cs10.2.23-1
- 18.0.5+~cs7.2.17-2
- 18.0.6+~cs7.2.17-1
- 18.0.6+~cs7.2.17-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-marked Ubuntu:26.04:LTS
- Softwareversionen
- 4.2.3+ds+~4.0.7-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/markedjs/marked/security/advisories/GHSA-5v2h-r2cx-5xgj
- https://github.com/markedjs/marked/commit/8f806573a3f6c6b7a39b8cdb66ab5ebb8d55a5f5
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/AIXDMC3CSHYW3YWVSQOXAWLUYQHAO5UX/
- https://nvd.nist.gov/vuln/detail/CVE-2022-21681