p PatchFirst

CVE-2022-21705

CVE-2022-21705 · Authenticated remote code execution in octobercms

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Octobercms is a self-hosted CMS platform based on the Laravel PHP Framework. In affected versions user input was not properly sanitized before rendering. An authenticated user with the permissions to create, modify and delete website pages can exploit this vulnerability to bypass `cms.safe_mode` / `cms.enableSafeMode` in order to execute arbitrary code. This issue only affects admin panels that rely on safe mode and restricted permissions. To exploit this vulnerability, an attacker must first have access to the backend area. The issue has been patched in Build 474 (v1.0.474) and v1.1.10. Users unable to upgrade should apply https://github.com/octobercms/library/commit/c393c5ce9ca2c5acc3ed6c9bb0dab5ffd61965fe to your installation manually.

CVSS 7.2 · Hoch · EPSS 8,6% · Öffentlicher Exploit · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • october

    Softwareversionen
    • < 1.0.474: Betroffen
    • >= 1.1.0, < 1.1.10: Betroffen
    • >= 2.0.0, < 2.1.27: Betroffen

    Keine Korrektur veröffentlicht

  • october/system Packagist

    Softwareversionen
    • v1.0.319
    • v1.0.320
    • v1.0.321
    • v1.0.322
    • v1.0.323
    • v1.0.324
    • v1.0.325
    • v1.0.326
    • v1.0.327
    • v1.0.328
    • v1.0.329
    • v1.0.330
    • v1.0.331
    • v1.0.332
    • v1.0.333
    • v1.0.334
    • v1.0.335
    • v1.0.336
    • v1.0.337
    • v1.0.338
    • v1.0.339
    • v1.0.340
    • v1.0.341
    • v1.0.342
    • v1.0.343
    • v1.0.344
    • v1.0.345
    • v1.0.346
    • v1.0.347
    • v1.0.348
    • v1.0.349
    • v1.0.350
    • v1.0.351
    • v1.0.352
    • v1.0.353
    • v1.0.354
    • v1.0.355
    • v1.0.356
    • v1.0.357
    • v1.0.358
    • v1.0.359
    • v1.0.360
    • v1.0.361
    • v1.0.362
    • v1.0.363
    • v1.0.364
    • v1.0.365
    • v1.0.366
    • v1.0.367
    • v1.0.368
    • v1.0.369
    • v1.0.370
    • v1.0.371
    • v1.0.372
    • v1.0.373
    • v1.0.374
    • v1.0.375
    • v1.0.376
    • v1.0.377
    • v1.0.378
    • v1.0.379
    • v1.0.380
    • v1.0.381
    • v1.0.382
    • v1.0.383
    • v1.0.384
    • v1.0.385
    • v1.0.386
    • v1.0.387
    • v1.0.388
    • v1.0.389
    • v1.0.390
    • v1.0.391
    • v1.0.392
    • v1.0.393
    • v1.0.394
    • v1.0.395
    • v1.0.396
    • v1.0.397
    • v1.0.398
    • v1.0.399
    • v1.0.400
    • v1.0.401
    • v1.0.402
    • v1.0.403
    • v1.0.404
    • v1.0.405
    • v1.0.406
    • v1.0.407
    • v1.0.408
    • v1.0.409
    • v1.0.410
    • v1.0.411
    • v1.0.412
    • v1.0.413
    • v1.0.414
    • v1.0.415
    • v1.0.416
    • v1.0.417
    • v1.0.418
    • v1.0.419
    • v1.0.420
    • v1.0.421
    • v1.0.422
    • v1.0.423
    • v1.0.424
    • v1.0.425
    • v1.0.426
    • v1.0.427
    • v1.0.428
    • v1.0.429
    • v1.0.430
    • v1.0.431
    • v1.0.432
    • v1.0.433
    • v1.0.434
    • v1.0.435
    • v1.0.436
    • v1.0.437
    • v1.0.438
    • v1.0.439
    • v1.0.440
    • v1.0.441
    • v1.0.442
    • v1.0.443
    • v1.0.444
    • v1.0.445
    • v1.0.446
    • v1.0.447
    • v1.0.448
    • v1.0.449
    • v1.0.450
    • v1.0.451
    • v1.0.452
    • v1.0.453
    • v1.0.454
    • v1.0.455
    • v1.0.456
    • v1.0.457
    • v1.0.458
    • v1.0.459
    • v1.0.460
    • v1.0.461
    • v1.0.462
    • v1.0.463
    • v1.0.464
    • v1.0.465
    • v1.0.466
    • v1.0.467
    • v1.0.468
    • v1.0.469
    • v1.0.470
    • v1.0.471
    • v1.0.472
    • v1.0.473
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.0.474

    Auf 1.0.474 aktualisieren

  • october/system Packagist

    Softwareversionen
    • v1.1.0
    • v1.1.1
    • v1.1.2
    • v1.1.3
    • v1.1.4
    • v1.1.5
    • v1.1.6
    • v1.1.9
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.1.0, < 1.1.10

    Auf 1.1.10 aktualisieren

  • october/system Packagist

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.0.0, < 2.1.27

    Auf 2.1.27 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →