p PatchFirst

CVE-2022-23648

CVE-2022-23648 · Insecure handling of image volumes in containerd CRI plugin

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

containerd is a container runtime available as a daemon for Linux and Windows. A bug was found in containerd prior to versions 1.6.1, 1.5.10, and 1.14.12 where containers launched through containerd’s CRI implementation on Linux with a specially-crafted image configuration could gain access to read-only copies of arbitrary files and directories on the host. This may bypass any policy-based enforcement on container setup (including a Kubernetes Pod Security Policy) and expose potentially sensitive information. Kubernetes and crictl can both be configured to use containerd’s CRI implementation. This bug has been fixed in containerd 1.6.1, 1.5.10, and 1.4.12. Users should update to these versions to resolve the issue.

CVSS 7.5 · Hoch · EPSS 27,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · containers

Betroffene Produkte und Versionen

  • containerd

    Softwareversionen
    • < 1.4.13: Betroffen
    • >= 1.5.0, < 1.5.10: Betroffen
    • >= 1.6.0, < 1.6.1: Betroffen

    Keine Korrektur veröffentlicht

  • containerd Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.6.1~ds1-1

    Auf 1.6.1~ds1-1 aktualisieren

  • containerd Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.6.1~ds1-1

    Auf 1.6.1~ds1-1 aktualisieren

  • containerd Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.6.1~ds1-1

    Auf 1.6.1~ds1-1 aktualisieren

  • containerd Ubuntu:18.04:LTS

    Softwareversionen
    • 0.2.5-0ubuntu2
    • 1.2.6-0ubuntu1~18.04.1
    • 1.2.6-0ubuntu1~18.04.2
    • 1.3.3-0ubuntu1~18.04.1
    • 1.3.3-0ubuntu1~18.04.2
    • 1.3.3-0ubuntu1~18.04.3
    • 1.3.3-0ubuntu1~18.04.4
    • 1.4.4-0ubuntu1~18.04.2
    • 1.5.2-0ubuntu1~18.04.1
    • 1.5.2-0ubuntu1~18.04.2
    • 1.5.2-0ubuntu1~18.04.3
    • 1.5.5-0ubuntu3~18.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.5.5-0ubuntu3~18.04.2

    Auf 1.5.5-0ubuntu3~18.04.2 aktualisieren

  • containerd Ubuntu:20.04:LTS

    Softwareversionen
    • 1.2.10-0ubuntu1
    • 1.3.2-0ubuntu1
    • 1.3.3-0ubuntu1
    • 1.3.3-0ubuntu2
    • 1.3.3-0ubuntu2.1
    • 1.3.3-0ubuntu2.2
    • 1.3.3-0ubuntu2.3
    • 1.4.4-0ubuntu1~20.04.2
    • 1.5.2-0ubuntu1~20.04.1
    • 1.5.2-0ubuntu1~20.04.2
    • 1.5.2-0ubuntu1~20.04.3
    • 1.5.5-0ubuntu3~20.04.1
    • 1.5.5-0ubuntu3~20.04.2
    • 1.5.9-0ubuntu1~20.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.5.9-0ubuntu1~20.04.4

    Auf 1.5.9-0ubuntu1~20.04.4 aktualisieren

  • containerd Ubuntu:22.04:LTS

    Softwareversionen
    • 1.5.5-0ubuntu3
    • 1.5.9-0ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.5.9-0ubuntu2

    Auf 1.5.9-0ubuntu2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →