CVE-2022-24728
CVE-2022-24728 · Cross-site Scripting in CKEditor4
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.
CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4 prior to version 4.18.0. The vulnerability allows someone to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. This problem has been patched in version 4.18.0. There are currently no known workarounds.
CVSS 5.4 · Mittel · EPSS 1,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · php · node
Betroffene Produkte und Versionen
ckeditor4
- Softwareversionen
- < 4.18.0: Betroffen
Keine Korrektur veröffentlicht
ckeditor Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.19.0+dfsg-1
Auf 4.19.0+dfsg-1 aktualisieren
ckeditor3 Debian:12
- Softwareversionen
- 3.6.6.1+dfsg-7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ckeditor4 npm
- Betroffene Versionsbereiche
- SEMVER: < 4.18.0
Auf 4.18.0 aktualisieren
drupal/core Packagist
- Softwareversionen
- 8.0.0
- 8.0.1
- 8.0.2
- 8.0.3
- 8.0.4
- 8.0.5
- 8.0.6
- 8.1.0
- 8.1.0-beta1
- 8.1.0-beta2
- 8.1.0-rc1
- 8.1.1
- 8.1.10
- 8.1.2
- 8.1.3
- 8.1.4
- 8.1.5
- 8.1.6
- 8.1.7
- 8.1.8
- 8.1.9
- 8.2.0
- 8.2.0-beta1
- 8.2.0-beta2
- 8.2.0-beta3
- 8.2.0-rc1
- 8.2.0-rc2
- 8.2.1
- 8.2.2
- 8.2.3
- 8.2.4
- 8.2.5
- 8.2.6
- 8.2.7
- 8.2.8
- 8.3.0
- 8.3.0-alpha1
- 8.3.0-beta1
- 8.3.0-rc1
- 8.3.0-rc2
- 8.3.1
- 8.3.2
- 8.3.3
- 8.3.4
- 8.3.5
- 8.3.6
- 8.3.7
- 8.3.8
- 8.3.9
- 8.4.0
- 8.4.0-alpha1
- 8.4.0-beta1
- 8.4.0-rc1
- 8.4.0-rc2
- 8.4.1
- 8.4.2
- 8.4.3
- 8.4.4
- 8.4.5
- 8.4.6
- 8.4.7
- 8.4.8
- 8.5.0
- 8.5.0-alpha1
- 8.5.0-beta1
- 8.5.0-rc1
- 8.5.1
- 8.5.10
- 8.5.11
- 8.5.12
- 8.5.13
- 8.5.14
- 8.5.15
- 8.5.2
- 8.5.3
- 8.5.4
- 8.5.5
- 8.5.6
- 8.5.7
- 8.5.8
- 8.5.9
- 8.6.0
- 8.6.0-alpha1
- 8.6.0-beta1
- 8.6.0-beta2
- 8.6.0-rc1
- 8.6.1
- 8.6.10
- 8.6.11
- 8.6.12
- 8.6.13
- 8.6.14
- 8.6.15
- 8.6.16
- 8.6.17
- 8.6.18
- 8.6.2
- 8.6.3
- 8.6.4
- 8.6.5
- 8.6.6
- 8.6.7
- 8.6.8
- 8.6.9
- 8.7.0
- 8.7.0-alpha1
- 8.7.0-alpha2
- 8.7.0-beta1
- 8.7.0-beta2
- 8.7.0-rc1
- 8.7.1
- 8.7.10
- 8.7.11
- 8.7.12
- 8.7.13
- 8.7.14
- 8.7.2
- 8.7.3
- 8.7.4
- 8.7.5
- 8.7.6
- 8.7.7
- 8.7.8
- 8.7.9
- 8.8.0
- 8.8.0-alpha1
- 8.8.0-beta1
- 8.8.0-rc1
- 8.8.1
- 8.8.10
- 8.8.11
- 8.8.12
- 8.8.2
- 8.8.3
- 8.8.4
- 8.8.5
- 8.8.6
- 8.8.7
- 8.8.8
- 8.8.9
- 8.9.0
- 8.9.0-beta1
- 8.9.0-beta2
- 8.9.0-beta3
- 8.9.0-rc1
- 8.9.1
- 8.9.10
- 8.9.11
- 8.9.12
- 8.9.13
- 8.9.14
- 8.9.15
- 8.9.16
- 8.9.17
- 8.9.18
- 8.9.19
- 8.9.2
- 8.9.20
- 8.9.3
- 8.9.4
- 8.9.5
- 8.9.6
- 8.9.7
- 8.9.8
- 8.9.9
- 9.0.0
- 9.0.0-alpha1
- 9.0.0-alpha2
- 9.0.0-beta1
- 9.0.0-beta2
- 9.0.0-beta3
- 9.0.0-rc1
- 9.0.1
- 9.0.10
- 9.0.11
- 9.0.12
- 9.0.13
- 9.0.14
- 9.0.2
- 9.0.3
- 9.0.4
- 9.0.5
- 9.0.6
- 9.0.7
- 9.0.8
- 9.0.9
- 9.1.0
- 9.1.0-alpha1
- 9.1.0-beta1
- 9.1.0-rc1
- 9.1.0-rc2
- 9.1.0-rc3
- 9.1.1
- 9.1.10
- 9.1.11
- 9.1.12
- 9.1.13
- 9.1.14
- 9.1.15
- 9.1.2
- 9.1.3
- 9.1.4
- 9.1.5
- 9.1.6
- 9.1.7
- 9.1.8
- 9.1.9
- 9.2.0
- 9.2.0-alpha1
- 9.2.0-beta1
- 9.2.0-beta2
- 9.2.0-beta3
- 9.2.0-rc1
- 9.2.1
- 9.2.10
- 9.2.11
- 9.2.12
- 9.2.13
- 9.2.14
- 9.2.2
- 9.2.3
- 9.2.4
- 9.2.5
- 9.2.6
- 9.2.7
- 9.2.8
- 9.2.9
- 9.3.0
- 9.3.1
- 9.3.2
- 9.3.3
- 9.3.4
- 9.3.5
- 9.3.6
- 9.3.7
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 8.0.0, < 9.2.15
- ECOSYSTEM: ≥ 9.3.0, < 9.3.8
Auf 9.2.15 aktualisieren; Auf 9.3.8 aktualisieren
ckeditor Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 4.4.4+dfsg1-3
- 4.5.6+dfsg-1
- 4.5.7+dfsg-1
- 4.5.7+dfsg-2
- 4.5.7+dfsg-2ubuntu0.16.04.1~esm1
- 4.5.7+dfsg-2ubuntu0.16.04.1~esm2
- 4.5.7+dfsg-2ubuntu0.16.04.1~esm3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ldap-account-manager Ubuntu:16.04:LTS
- Softwareversionen
- 4.9-1
- 5.1-1
- 5.2-1
- 5.2-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
request-tracker4 Ubuntu:16.04:LTS
- Softwareversionen
- 4.2.11-2
- 4.2.12-3
- 4.2.12-4
- 4.2.12-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ckeditor Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 4.5.7+dfsg-2
- 4.5.7+dfsg-2ubuntu0.18.04.1
- 4.5.7+dfsg-2ubuntu0.18.04.1+esm1
- 4.5.7+dfsg-2ubuntu0.18.04.1+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ckeditor3 Ubuntu:18.04:LTS
- Softwareversionen
- 3.6.6.1+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ldap-account-manager Ubuntu:18.04:LTS
- Softwareversionen
- 5.7-1
- 6.1-1
- 6.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
request-tracker4 Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 4.4.1-5
- 4.4.2-1
- 4.4.2-2
- 4.4.2-2ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ckeditor Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 4.11.1+dfsg-1
- 4.12.1+dfsg-1
- 4.12.1+dfsg-1ubuntu0.1
- 4.12.1+dfsg-1ubuntu0.1+esm1
- 4.12.1+dfsg-1ubuntu0.1+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ckeditor3 Ubuntu:20.04:LTS
- Softwareversionen
- 3.6.6.1+dfsg-3
- 3.6.6.1+dfsg-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ldap-account-manager Ubuntu:20.04:LTS
- Softwareversionen
- 6.7-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
request-tracker4 Ubuntu:20.04:LTS
- Softwareversionen
- 4.4.3-2
- 4.4.3-2+deb10u3build0.20.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ckeditor3 Ubuntu:22.04:LTS
- Softwareversionen
- 3.6.6.1+dfsg-7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ldap-account-manager Ubuntu:22.04:LTS
- Softwareversionen
- 7.5-1
- 7.7-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
request-tracker4 Ubuntu:22.04:LTS
- Softwareversionen
- 4.4.4+dfsg-2ubuntu1
- 4.4.4+dfsg-2ubuntu1.22.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ckeditor Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 4.16.0+dfsg-2
- 4.16.2+dfsg-1
- 4.16.2+dfsg-1ubuntu0.1~esm1
- 4.16.2+dfsg-1ubuntu0.1~esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ckeditor3 Ubuntu:24.04:LTS
- Softwareversionen
- 3.6.6.1+dfsg-7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ldap-account-manager Ubuntu:24.04:LTS
- Softwareversionen
- 8.3-1
- 8.5-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
request-tracker4 Ubuntu:24.04:LTS
- Softwareversionen
- 4.4.4+dfsg-2ubuntu1
- 4.4.4+dfsg-2ubuntu2
- 4.4.7+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ldap-account-manager Ubuntu:25.10
- Softwareversionen
- 9.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-4fc4-4p5g-6w89
- https://github.com/ckeditor/ckeditor4/commit/d158413449692d920a778503502dcb22881bc949
- https://ckeditor.com/cke4/release/CKEditor-4.18.0
- https://www.oracle.com/security-alerts/cpujul2022.html
- https://www.drupal.org/sa-core-2022-005
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WOZGMCYDB2OKKULFXZKM6V7JJW4ZZHJP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VR76VBN5GW5QUBJFHVXRX36UZ6YTCMW6/
- https://nvd.nist.gov/vuln/detail/CVE-2022-24728