CVE-2022-24879
CVE-2022-24879 · Malfunction of Cross-Site Request Forgery token validation
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Shopware is an open source e-commerce software platform. Versions prior to 5.7.9 are vulnerable to malfunction of cross-site request forgery (CSRF) token validation. Under certain circumstances, the CSRF tokens were not generated anew and not validated correctly. This issue is fixed in version 5.7.9. Users of older versions may attempt to mitigate the vulnerability by using the Shopware security plugin.
CVSS 7.5 · Hoch · EPSS 0,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: php
Betroffene Produkte und Versionen
shopware
- Softwareversionen
- >= 5.2.0, < 5.7.9: Betroffen
Keine Korrektur veröffentlicht
shopware/shopware Packagist
- Softwareversionen
- 5.3.0
- v5.2.0
- v5.2.1
- v5.2.10
- v5.2.11
- v5.2.12
- v5.2.13
- v5.2.14
- v5.2.15
- v5.2.16
- v5.2.17
- v5.2.18
- v5.2.19
- v5.2.2
- v5.2.20
- v5.2.21
- v5.2.22
- v5.2.23
- v5.2.24
- v5.2.25
- v5.2.26
- v5.2.27
- v5.2.3
- v5.2.4
- v5.2.5
- v5.2.6
- v5.2.7
- v5.2.8
- v5.2.9
- v5.3.4
- v5.3.5
- v5.3.6
- v5.3.7
- v5.4.0
- v5.4.0-RC1
- v5.4.1
- v5.4.2
- v5.4.3
- v5.4.4
- v5.4.5
- v5.4.6
- v5.5.0
- v5.5.0-BETA1
- v5.5.0-RC1
- v5.5.1
- v5.5.10
- v5.5.2
- v5.5.3
- v5.5.4
- v5.5.5
- v5.5.6
- v5.5.7
- v5.5.8
- v5.5.9
- v5.6.0
- v5.6.0-RC1
- v5.6.1
- v5.6.10
- v5.6.2
- v5.6.3
- v5.6.4
- v5.6.5
- v5.6.6
- v5.6.7
- v5.6.8
- v5.6.9
- v5.7.0
- v5.7.0-RC1
- v5.7.0-RC2
- v5.7.1
- v5.7.2
- v5.7.3
- v5.7.4
- v5.7.5
- v5.7.6
- v5.7.7
- v5.7.8
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 5.2.0, < 5.7.9
Auf 5.7.9 aktualisieren