p PatchFirst

CVE-2022-29221

CVE-2022-29221 · PHP Code Injection by malicious block or filename in Smarty

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.

Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.45 and 4.1.1, template authors could inject php code by choosing a malicious {block} name or {include} file name. Sites that cannot fully trust template authors should upgrade to versions 3.1.45 or 4.1.1 to receive a patch for this issue. There are currently no known workarounds.

CVSS 8.8 · Hoch · EPSS 4,9% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · php

Betroffene Produkte und Versionen

  • smarty

    Softwareversionen
    • < 3.1.45: Betroffen
    • >= 4.0.0, < 4.1.1: Betroffen

    Keine Korrektur veröffentlicht

  • smarty3 Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.45-1

    Auf 3.1.45-1 aktualisieren

  • smarty3 Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.45-1

    Auf 3.1.45-1 aktualisieren

  • smarty3 Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.45-1

    Auf 3.1.45-1 aktualisieren

  • smarty4 Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.1.1-1

    Auf 4.1.1-1 aktualisieren

  • smarty4 Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.1.1-1

    Auf 4.1.1-1 aktualisieren

  • smarty4 Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.1.1-1

    Auf 4.1.1-1 aktualisieren

  • smarty/smarty Packagist

    Softwareversionen
    • v2.6.24
    • v2.6.25
    • v2.6.26
    • v2.6.27
    • v2.6.28
    • v2.6.29
    • v2.6.30
    • v2.6.31
    • v2.6.33
    • v3.1.11
    • v3.1.12
    • v3.1.13
    • v3.1.14
    • v3.1.15
    • v3.1.16
    • v3.1.17
    • v3.1.18
    • v3.1.19
    • v3.1.20
    • v3.1.21
    • v3.1.23
    • v3.1.24
    • v3.1.25
    • v3.1.26
    • v3.1.27
    • v3.1.28
    • v3.1.29
    • v3.1.30
    • v3.1.31
    • v3.1.32
    • v3.1.33
    • v3.1.34
    • v3.1.35
    • v3.1.36
    • v3.1.37
    • v3.1.37.1
    • v3.1.38
    • v3.1.39
    • v3.1.40
    • v3.1.41
    • v3.1.42
    • v3.1.43
    • v3.1.44
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.45

    Auf 3.1.45 aktualisieren

  • smarty/smarty Packagist

    Softwareversionen
    • v4.0.0
    • v4.0.1
    • v4.0.2
    • v4.0.3
    • v4.0.4
    • v4.1.0
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 4.0.0, < 4.1.1

    Auf 4.1.1 aktualisieren

  • collabtive Ubuntu:16.04:LTS

    Softwareversionen
    • 2.0+dfsg-6
    • 2.0+dfsg-6ubuntu1
    • 2.0+dfsg-6ubuntu1.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • galette Ubuntu:16.04:LTS

    Softwareversionen
    • 0.8+dfsg-1
    • 0.8+dfsg-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • gosa Ubuntu:16.04:LTS

    Softwareversionen
    • 2.7.4+reloaded2-2
    • 2.7.4+reloaded2-5
    • 2.7.4+reloaded2-6
    • 2.7.4+reloaded2-7
    • 2.7.4+reloaded2-8
    • 2.7.4+reloaded2-9
    • 2.7.4+reloaded2-9ubuntu1
    • 2.7.4+reloaded2-9ubuntu1.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • smarty3 Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 3.1.21-1
    • 3.1.21-1ubuntu1
    • 3.1.21-1ubuntu1+esm1
    • 3.1.21-1ubuntu1+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • gosa Ubuntu:18.04:LTS

    Softwareversionen
    • 2.7.4+reloaded2-13ubuntu1
    • 2.7.4+reloaded3-2ubuntu1
    • 2.7.4+reloaded3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • postfixadmin Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 3.0.2-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.0.2-2ubuntu0.1~esm1

    Auf 3.0.2-2ubuntu0.1~esm1 aktualisieren

  • smarty3 Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 3.1.31+20161214.1.c7d42e4+selfpack1-2
    • 3.1.31+20161214.1.c7d42e4+selfpack1-3
    • 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1
    • 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • gosa Ubuntu:20.04:LTS

    Softwareversionen
    • 2.7.4+reloaded3-10
    • 2.7.4+reloaded3-10ubuntu1
    • 2.7.4+reloaded3-11
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • postfixadmin Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 3.2.1-2
    • 3.2.1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.2.1-3ubuntu0.1~esm1

    Auf 3.2.1-3ubuntu0.1~esm1 aktualisieren

  • smarty3 Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 3.1.33+20180830.1.3a78a21f+selfpack1-1
    • 3.1.34+20190228.1.c9f0de05+selfpack1-1
    • 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1~esm1
    • 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1
    • 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • gosa Ubuntu:22.04:LTS

    Softwareversionen
    • 2.7.4+reloaded3-16build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • smarty3 Ubuntu:22.04:LTS

    Softwareversionen
    • 3.1.39-2
    • 3.1.39-2ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.39-2ubuntu1.22.04.1

    Auf 3.1.39-2ubuntu1.22.04.1 aktualisieren

  • postfixadmin Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 3.3.7-1
    • 3.3.10-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.3.10-2ubuntu0.1~esm1

    Auf 3.3.10-2ubuntu0.1~esm1 aktualisieren

  • gosa Ubuntu:24.04:LTS

    Softwareversionen
    • 2.8~git20230203.10abe45+dfsg-8
    • 2.8~git20230203.10abe45+dfsg-9
    • 2.8~git20230203.10abe45+dfsg-10
    • 2.8~git20230203.10abe45+dfsg-11
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • gosa Ubuntu:25.10

    Softwareversionen
    • 2.8~git20230203.10abe45+dfsg-18
    • 2.8~git20230203.10abe45+dfsg-19
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →