p PatchFirst

CVE-2022-29244

CVE-2022-29244 · npm packing does not respect root-level ignore files in workspaces

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

npm pack ignores root-level .gitignore and .npmignore file exclusion directives when run in a workspace or with a workspace flag (ie. `--workspaces`, `--workspace=<name>`). Anyone who has run `npm pack` or `npm publish` inside a workspace, as of v7.9.0 and v7.13.0 respectively, may be affected and have published files into the npm registry they did not intend to include. Users should upgrade to the latest, patched version of npm v8.11.0, run: npm i -g npm@latest . Node.js versions v16.15.1, v17.19.1, and v18.3.0 include the patched v8.11.0 version of npm.

CVSS 7.5 · Hoch · EPSS 4,0% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • npm

    Softwareversionen
    • ≥ 7.9.0, < 7.9.0*: Betroffen (custom)
    • ≥ 8.11.0, < 8.11.0: Betroffen (custom)

    Keine Korrektur veröffentlicht

  • npm npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 7.9.0, < 8.11.0

    Auf 8.11.0 aktualisieren

  • npm Ubuntu:14.04:LTS

    Softwareversionen
    • 1.2.18~dfsg-3
    • 1.3.10~dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • npm Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1.4.21+ds-2
    • 3.5.2-0ubuntu4
    • 3.5.2-0ubuntu4.1.16.04.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • npm Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 3.5.2-0ubuntu4
    • 3.5.2-0ubuntu4.1.18.04.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • npm Ubuntu:20.04:LTS

    Softwareversionen
    • 5.8.0+ds6-4
    • 6.14.4+ds-1ubuntu2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • npm Ubuntu:22.04:LTS

    Softwareversionen
    • 7.5.2+ds-2
    • 7.24.2+ds-1
    • 7.24.2+ds-2
    • 8.3.0~ds-1
    • 8.3.0~ds-2
    • 8.3.2~ds-1
    • 8.5.0~ds-1
    • 8.5.1~ds-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • npm Ubuntu:24.04:LTS

    Softwareversionen
    • 9.2.0~ds1-1
    • 9.2.0~ds1-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • npm Ubuntu:25.10

    Softwareversionen
    • 9.2.0~ds1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • npm Ubuntu:26.10

    Softwareversionen
    • 9.2.0~ds3-1
    • 11.16.0+ds2-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • npm Ubuntu:26.04:LTS

    Softwareversionen
    • 9.2.0~ds1-3
    • 9.2.0~ds2-2
    • 9.2.0~ds3-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →