CVE-2022-30699
CVE-2022-30699 · Novel "ghost domain names" attack by updating almost expired delegation information
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
NLnet Labs Unbound, up to and including version 1.16.1, is vulnerable to a novel type of the "ghost domain names" attack. The vulnerability works by targeting an Unbound instance. Unbound is queried for a rogue domain name when the cached delegation information is about to expire. The rogue nameserver delays the response so that the cached delegation information is expired. Upon receiving the delayed answer containing the delegation information, Unbound overwrites the now expired entries. This action can be repeated when the delegation information is about to expire making the rogue delegation information ever-updating. From version 1.16.2 on, Unbound stores the start time for a query and uses that to decide if the cached delegation information can be overwritten.
CVSS 6.5 · Mittel · EPSS 1,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
unbound
- Softwareversionen
- ≥ unspecified, ≤ 1.16.1: Betroffen (custom)
Keine Korrektur veröffentlicht
unbound Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.16.2-1
Auf 1.16.2-1 aktualisieren
unbound Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.16.2-1
Auf 1.16.2-1 aktualisieren
unbound Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.16.2-1
Auf 1.16.2-1 aktualisieren
unbound Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 1.4.20-1
- 1.4.21-1
- 1.4.21-1ubuntu1
- 1.4.21-1ubuntu2
- 1.4.22-1ubuntu1
- 1.4.22-1ubuntu2
- 1.4.22-1ubuntu3
- 1.4.22-1ubuntu4
- 1.4.22-1ubuntu4.14.04.1
- 1.4.22-1ubuntu4.14.04.2
- 1.4.22-1ubuntu4.14.04.3
- 1.4.22-1ubuntu4.14.04.3+esm1
- 1.4.22-1ubuntu4.14.04.3+esm2
- 1.4.22-1ubuntu4.14.04.3+esm3
- 1.4.22-1ubuntu4.14.04.3+esm4
- 1.4.22-1ubuntu4.14.04.3+esm5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
unbound Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1.4.22-1ubuntu6
- 1.5.7-1ubuntu1
- 1.5.7-1ubuntu2
- 1.5.8-1ubuntu1
- 1.5.8-1ubuntu1.1
- 1.5.8-1ubuntu1.1+esm1
- 1.5.8-1ubuntu1.1+esm2
- 1.5.8-1ubuntu1.1+esm3
- 1.5.8-1ubuntu1.1+esm4
- 1.5.8-1ubuntu1.1+esm5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
unbound Ubuntu:18.04:LTS
- Softwareversionen
- 1.6.5-1
- 1.6.7-1
- 1.6.7-1build1
- 1.6.7-1ubuntu1
- 1.6.7-1ubuntu2
- 1.6.7-1ubuntu2.1
- 1.6.7-1ubuntu2.2
- 1.6.7-1ubuntu2.3
- 1.6.7-1ubuntu2.4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.7-1ubuntu2.5
Auf 1.6.7-1ubuntu2.5 aktualisieren
unbound Ubuntu:20.04:LTS
- Softwareversionen
- 1.9.0-2ubuntu1
- 1.9.0-2ubuntu2
- 1.9.4-2
- 1.9.4-2ubuntu1
- 1.9.4-2ubuntu1.1
- 1.9.4-2ubuntu1.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.9.4-2ubuntu1.3
Auf 1.9.4-2ubuntu1.3 aktualisieren
unbound Ubuntu:22.04:LTS
- Softwareversionen
- 1.13.1-1ubuntu1
- 1.13.1-1ubuntu3
- 1.13.1-1ubuntu5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.13.1-1ubuntu5.1
Auf 1.13.1-1ubuntu5.1 aktualisieren
Originalquellen
- https://www.nlnetlabs.nl/downloads/unbound/CVE-2022-30698_CVE-2022-30699.txt
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/5L3ZFWZZFPBIL654BG75RWXUMPFQJ5EC/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/D35CX4SCZVNKZTWJXPDFTHWZHINMGEZD/
- https://security.gentoo.org/glsa/202212-02
- https://lists.debian.org/debian-lts-announce/2023/03/msg00024.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-30699