CVE-2022-31198
CVE-2022-31198 · GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
OpenZeppelin Contracts is a library for secure smart contract development. This issue concerns instances of Governor that use the module `GovernorVotesQuorumFraction`, a mechanism that determines quorum requirements as a percentage of the voting token's total supply. In affected instances, when a proposal is passed to lower the quorum requirements, past proposals may become executable if they had been defeated only due to lack of quorum, and the number of votes it received meets the new quorum requirement. Analysis of instances on chain found only one proposal that met this condition, and we are actively monitoring for new occurrences of this particular issue. This issue has been patched in v4.7.2. Users are advised to upgrade. Users unable to upgrade should consider avoiding lowering quorum requirements if a past proposal was defeated for lack of quorum.
CVSS 7.5 · Hoch · EPSS 0,8% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: node
Betroffene Produkte und Versionen
openzeppelin-contracts
- Softwareversionen
- >= 4.3.0, < 4.7.2: Betroffen
Keine Korrektur veröffentlicht
@openzeppelin/contracts npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 4.3.0, < 4.7.2
Auf 4.7.2 aktualisieren
@openzeppelin/contracts-upgradeable npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 4.3.0, < 4.7.2
Auf 4.7.2 aktualisieren