CVE-2022-32886
CVE-2022-32886
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
A buffer overflow issue was addressed with improved memory handling. This issue is fixed in Safari 16, iOS 16, iOS 15.7 and iPadOS 15.7. Processing maliciously crafted web content may lead to arbitrary code execution.
CVSS 8.8 · Hoch · EPSS 1,9% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
ios
- Softwareversionen
- ≥ unspecified, < 16: Betroffen (custom)
Auf 16 aktualisieren
safari
- Softwareversionen
- ≥ unspecified, < 16: Betroffen (custom)
Auf 16 aktualisieren
ios and ipados
- Softwareversionen
- ≥ unspecified, < 15.7: Betroffen (custom)
Auf 15.7 aktualisieren
webkit2gtk Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.38.0-1
Auf 2.38.0-1 aktualisieren
webkit2gtk Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.38.0-1
Auf 2.38.0-1 aktualisieren
webkit2gtk Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.38.0-1
Auf 2.38.0-1 aktualisieren
wpewebkit Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.38.0-1
Auf 2.38.0-1 aktualisieren
wpewebkit Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.38.0-1
Auf 2.38.0-1 aktualisieren
wpewebkit Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.38.0-1
Auf 2.38.0-1 aktualisieren
qtwebkit-opensource-src Ubuntu:16.04:LTS
- Softwareversionen
- 5.4.2+dfsg-1ubuntu2.1
- 5.5.1+dfsg-2ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
webkit2gtk Ubuntu:16.04:LTS
- Softwareversionen
- 2.8.5+dfsg1-3
- 2.10.3+dfsg1-1
- 2.10.4+dfsg1-1
- 2.10.5-1
- 2.10.6-1
- 2.10.6-1ubuntu1
- 2.10.8-1ubuntu1
- 2.10.9-1ubuntu1
- 2.12.5-0ubuntu0.16.04.1
- 2.14.2-0ubuntu0.16.04.1
- 2.14.3-0ubuntu0.16.04.1
- 2.14.5-0ubuntu0.16.04.1
- 2.16.1-0ubuntu0.16.04.1
- 2.16.1-0ubuntu0.16.04.2
- 2.16.2-0ubuntu0.16.04.1
- 2.16.3-0ubuntu0.16.04.1
- 2.16.6-0ubuntu0.16.04.1
- 2.18.0-0ubuntu0.16.04.2
- 2.18.3-0ubuntu0.16.04.1
- 2.18.4-0ubuntu0.16.04.1
- 2.18.5-0ubuntu0.16.04.1
- 2.18.6-0ubuntu0.16.04.1
- 2.20.1-0ubuntu0.16.04.1
- 2.20.2-0ubuntu0.16.04.1
- 2.20.3-0ubuntu0.16.04.1
- 2.20.5-0ubuntu0.16.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
qtwebkit-source Ubuntu:16.04:LTS
- Softwareversionen
- 2.3.2-0ubuntu10
- 2.3.2-0ubuntu11
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
webkitgtk Ubuntu:16.04:LTS
- Softwareversionen
- 2.4.9-2ubuntu2
- 2.4.10-0ubuntu1
- 2.4.11-0ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
webkit2gtk Ubuntu:18.04:LTS
- Softwareversionen
- 2.18.0-2
- 2.18.0-2build1
- 2.18.2-1
- 2.18.3-1
- 2.18.4-1
- 2.18.6-1
- 2.19.91-1ubuntu1
- 2.19.92-1
- 2.20.0-1
- 2.20.0-2
- 2.20.0-2ubuntu1
- 2.20.1-1
- 2.20.2-0ubuntu0.18.04.1
- 2.20.3-0ubuntu0.18.04.1
- 2.20.5-0ubuntu0.18.04.1
- 2.22.2-0ubuntu0.18.04.1
- 2.22.2-0ubuntu0.18.04.2
- 2.22.4-0ubuntu0.18.04.1
- 2.22.5-0ubuntu0.18.04.1
- 2.22.6-0ubuntu0.18.04.1
- 2.24.1-0ubuntu0.18.04.1
- 2.24.2-0ubuntu0.18.04.1
- 2.24.4-0ubuntu0.18.04.1
- 2.26.1-0ubuntu0.18.04.1
- 2.26.2-0ubuntu0.18.04.1
- 2.26.3-0ubuntu0.18.04.1
- 2.26.4-0ubuntu0.18.04.1
- 2.28.0-0ubuntu0.18.04.3
- 2.28.1-0ubuntu0.18.04.1
- 2.28.2-0ubuntu0.18.04.1
- 2.28.3-0ubuntu0.18.04.1
- 2.28.4-0ubuntu0.18.04.1
- 2.30.3-0ubuntu0.18.04.1
- 2.30.5-0ubuntu0.18.04.1
- 2.30.6-0ubuntu0.18.04.1
- 2.32.0-0ubuntu0.18.04.1
- 2.32.3-0ubuntu0.18.04.1
- 2.32.4-0ubuntu0.18.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
qtwebkit-opensource-src Ubuntu:18.04:LTS
- Softwareversionen
- 5.9.1+dfsg-5ubuntu1
- 5.9.1+dfsg-5ubuntu3
- 5.212.0~alpha2-5build2
- 5.212.0~alpha2-5build4
- 5.212.0~alpha2-7
- 5.212.0~alpha2-7build2
- 5.212.0~alpha2-7ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
qtwebkit-source Ubuntu:18.04:LTS
- Softwareversionen
- 2.3.2-0ubuntu13
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
webkitgtk Ubuntu:18.04:LTS
- Softwareversionen
- 2.4.11-3
- 2.4.11-3ubuntu2
- 2.4.11-3ubuntu3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
webkit2gtk Ubuntu:20.04:LTS
- Softwareversionen
- 2.26.1-3
- 2.26.2-1
- 2.26.3-1ubuntu2
- 2.26.4-1ubuntu1
- 2.28.0-1ubuntu2
- 2.28.1-1
- 2.28.2-0ubuntu0.20.04.1
- 2.28.3-0ubuntu0.20.04.1
- 2.28.4-0ubuntu0.20.04.1
- 2.30.3-0ubuntu0.20.04.1
- 2.30.5-0ubuntu0.20.04.1
- 2.30.6-0ubuntu0.20.04.1
- 2.32.0-0ubuntu0.20.04.1
- 2.32.3-0ubuntu0.20.04.1
- 2.32.4-0ubuntu0.20.04.1
- 2.34.1-0ubuntu0.20.04.1
- 2.34.3-0ubuntu0.20.04.1
- 2.34.4-0ubuntu0.20.04.1
- 2.34.6-0ubuntu0.20.04.1
- 2.36.0-0ubuntu0.20.04.3
- 2.36.2-0ubuntu0.20.04.1
- 2.36.3-0ubuntu0.20.04.1
- 2.36.4-0ubuntu0.20.04.1
- 2.36.6-0ubuntu0.20.04.1
- 2.36.7-0ubuntu0.20.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.36.8-0ubuntu0.20.04.1
Auf 2.36.8-0ubuntu0.20.04.1 aktualisieren
qtwebkit-opensource-src Ubuntu:20.04:LTS
- Softwareversionen
- 5.212.0~alpha3-3
- 5.212.0~alpha3-5
- 5.212.0~alpha3-6
- 5.212.0~alpha3-7
- 5.212.0~alpha4-1
- 5.212.0~alpha4-1ubuntu1
- 5.212.0~alpha4-1ubuntu2
- 5.212.0~alpha4-1ubuntu2.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
wpewebkit Ubuntu:20.04:LTS
- Softwareversionen
- 2.26.3-1
- 2.26.4-1
- 2.26.4-1build1
- 2.28.0-1
- 2.28.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
qtwebkit-opensource-src Ubuntu:22.04:LTS
- Softwareversionen
- 5.212.0~alpha4-12
- 5.212.0~alpha4-13
- 5.212.0~alpha4-14
- 5.212.0~alpha4-14build1
- 5.212.0~alpha4-14ubuntu2
- 5.212.0~alpha4-15ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
webkit2gtk Ubuntu:22.04:LTS
- Softwareversionen
- 2.34.0-1ubuntu1
- 2.34.1-1ubuntu1
- 2.34.2-1ubuntu1
- 2.34.3-1
- 2.35.3-1ubuntu1
- 2.35.90-1ubuntu1
- 2.36.0-2ubuntu1
- 2.36.2-0ubuntu0.22.04.1
- 2.36.3-0ubuntu0.22.04.1
- 2.36.4-0ubuntu0.22.04.1
- 2.36.6-0ubuntu0.22.04.1
- 2.36.7-0ubuntu0.22.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.36.8-0ubuntu0.22.04.1
Auf 2.36.8-0ubuntu0.22.04.1 aktualisieren
wpewebkit Ubuntu:22.04:LTS
- Softwareversionen
- 2.32.4-1
- 2.34.1-1
- 2.34.2-1
- 2.34.3-1
- 2.34.4-1
- 2.34.5-1
- 2.34.6-1
- 2.36.0-2ubuntu2
- 2.36.0-2ubuntu3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
qtwebkit-opensource-src Ubuntu:24.04:LTS
- Softwareversionen
- 5.212.0~alpha4-33
- 5.212.0~alpha4-33build1
- 5.212.0~alpha4-34
- 5.212.0~alpha4-34ubuntu3
- 5.212.0~alpha4-34ubuntu4
- 5.212.0~alpha4-36
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://support.apple.com/en-us/HT213446
- https://support.apple.com/en-us/HT213445
- https://support.apple.com/en-us/HT213442
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/KDV6OLKDTL55NH4LNSMLQ4D6LLSX6JU2/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/74MXH2U5GA4CX3L3NLYP4TBO4O2VOPBJ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TDNT32WIARRD2ANWKGCTTIQXI6OII7HZ/
- https://www.debian.org/security/2022/dsa-5240
- https://www.debian.org/security/2022/dsa-5241
- https://lists.debian.org/debian-lts-announce/2022/09/msg00034.html
- http://seclists.org/fulldisclosure/2022/Oct/41
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/39
- https://security.gentoo.org/glsa/202305-32
- https://nvd.nist.gov/vuln/detail/CVE-2022-32886