p PatchFirst

CVE-2022-35652

CVE-2022-35652

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

An open redirect issue was found in Moodle due to improper sanitization of user-supplied data in mobile auto-login feature. A remote attacker can create a link that leads to a trusted website, however, when clicked, it redirects the victims to arbitrary URL/domain. Successful exploitation of this vulnerability may allow a remote attacker to perform a phishing attack and steal potentially sensitive information.

CVSS 6.1 · Mittel · EPSS 1,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · php

Betroffene Produkte und Versionen

  • moodle

    Softwareversionen
    • Fixed in moodle 4.0.2, moodle 3.11.8, moodle 3.9.15: Betroffen

    Keine Korrektur veröffentlicht

  • moodle/moodle Packagist

    Softwareversionen
    • v4.0.0
    • v4.0.0-beta
    • v4.0.0-rc1
    • v4.0.0-rc2
    • v4.0.0-rc3
    • v4.0.0-rc4
    • v4.0.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 4.0, < 4.0.2

    Auf 4.0.2 aktualisieren

  • moodle/moodle Packagist

    Softwareversionen
    • v3.11.0
    • v3.11.0-beta
    • v3.11.0-rc1
    • v3.11.0-rc2
    • v3.11.1
    • v3.11.2
    • v3.11.3
    • v3.11.4
    • v3.11.5
    • v3.11.6
    • v3.11.7
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.11, < 3.11.8

    Auf 3.11.8 aktualisieren

  • moodle/moodle Packagist

    Softwareversionen
    • v3.9.0
    • v3.9.0-beta
    • v3.9.0-rc1
    • v3.9.0-rc2
    • v3.9.0-rc3
    • v3.9.1
    • v3.9.10
    • v3.9.11
    • v3.9.12
    • v3.9.13
    • v3.9.14
    • v3.9.2
    • v3.9.3
    • v3.9.4
    • v3.9.5
    • v3.9.6
    • v3.9.7
    • v3.9.8
    • v3.9.9
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.9, < 3.9.15

    Auf 3.9.15 aktualisieren

  • moodle Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 2.7.9+dfsg-1
    • 2.7.10+dfsg-1
    • 2.7.11+dfsg-1
    • 2.7.11+dfsg-2
    • 2.7.12+dfsg-1
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • moodle Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →