p PatchFirst

CVE-2022-36109

CVE-2022-36109 · Moby vulnerability relating to supplementary group permissions

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Moby is an open-source project created by Docker to enable software containerization. A bug was found in Moby (Docker Engine) where supplementary groups are not set up properly. If an attacker has direct access to a container and manipulates their supplementary group access, they may be able to use supplementary group access to bypass primary group restrictions in some cases, potentially gaining access to sensitive information or gaining the ability to execute code in that container. This bug is fixed in Moby (Docker Engine) 20.10.18. Running containers should be stopped and restarted for the permissions to be fixed. For users unable to upgrade, this problem can be worked around by not using the `"USER $USERNAME"` Dockerfile instruction. Instead by calling `ENTRYPOINT ["su", "-", "user"]` the supplementary groups will be set up properly.

CVSS 5.3 · Mittel · EPSS 1,0% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · containers

Betroffene Produkte und Versionen

  • docker engine

    Softwareversionen
    • < 20.10.18: Betroffen

    Keine Korrektur veröffentlicht

  • docker.io Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 20.10.19+dfsg1-1

    Auf 20.10.19+dfsg1-1 aktualisieren

  • docker.io Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 20.10.19+dfsg1-1

    Auf 20.10.19+dfsg1-1 aktualisieren

  • docker.io Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 20.10.19+dfsg1-1

    Auf 20.10.19+dfsg1-1 aktualisieren

  • docker.io Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1.6.2~dfsg1-1ubuntu4
    • 1.10.2-0ubuntu3
    • 1.10.2-0ubuntu4
    • 1.10.3-0ubuntu1
    • 1.10.3-0ubuntu4
    • 1.10.3-0ubuntu5
    • 1.10.3-0ubuntu6
    • 1.11.2-0ubuntu5~16.04
    • 1.12.1-0ubuntu13~16.04.1
    • 1.12.3-0ubuntu4~16.04.2
    • 1.12.6-0ubuntu1~16.04.1
    • 1.13.1-0ubuntu1~16.04.2
    • 17.03.2-0ubuntu2~16.04.1
    • 18.06.1-0ubuntu1~16.04.2
    • 18.06.1-0ubuntu1.2~16.04.1
    • 18.09.2-0ubuntu1~16.04.1
    • 18.09.5-0ubuntu1~16.04.2
    • 18.09.7-0ubuntu1~16.04.1
    • 18.09.7-0ubuntu1~16.04.4
    • 18.09.7-0ubuntu1~16.04.5
    • 18.09.7-0ubuntu1~16.04.6
    • 18.09.7-0ubuntu1~16.04.7
    • 18.09.7-0ubuntu1~16.04.9+esm1
    • 18.09.7-0ubuntu1~16.04.9+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • docker.io Ubuntu:18.04:LTS

    Softwareversionen
    • 1.13.1-0ubuntu6
    • 17.03.2-0ubuntu1
    • 17.03.2-0ubuntu3
    • 17.03.2-0ubuntu5
    • 17.12.1-0ubuntu1
    • 18.06.1-0ubuntu1~18.04.1
    • 18.06.1-0ubuntu1.2~18.04.1
    • 18.09.2-0ubuntu1~18.04.1
    • 18.09.5-0ubuntu1~18.04.2
    • 18.09.7-0ubuntu1~18.04.1
    • 18.09.7-0ubuntu1~18.04.3
    • 18.09.7-0ubuntu1~18.04.4
    • 19.03.6-0ubuntu1~18.04.1
    • 19.03.6-0ubuntu1~18.04.2
    • 19.03.6-0ubuntu1~18.04.3
    • 20.10.2-0ubuntu1~18.04.2
    • 20.10.2-0ubuntu1~18.04.3
    • 20.10.7-0ubuntu1~18.04.1
    • 20.10.7-0ubuntu1~18.04.2
    • 20.10.7-0ubuntu5~18.04.2
    • 20.10.7-0ubuntu5~18.04.3
    • 20.10.12-0ubuntu2~18.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 20.10.21-0ubuntu1~18.04.2

    Auf 20.10.21-0ubuntu1~18.04.2 aktualisieren

  • docker.io Ubuntu:20.04:LTS

    Softwareversionen
    • 19.03.2-0ubuntu1
    • 19.03.6-0ubuntu1
    • 19.03.8-0ubuntu1
    • 19.03.8-0ubuntu1.20.04
    • 19.03.8-0ubuntu1.20.04.1
    • 19.03.8-0ubuntu1.20.04.2
    • 20.10.2-0ubuntu1~20.04.2
    • 20.10.2-0ubuntu1~20.04.3
    • 20.10.7-0ubuntu1~20.04.1
    • 20.10.7-0ubuntu1~20.04.2
    • 20.10.7-0ubuntu5~20.04.1
    • 20.10.7-0ubuntu5~20.04.2
    • 20.10.12-0ubuntu2~20.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 20.10.21-0ubuntu1~20.04.1

    Auf 20.10.21-0ubuntu1~20.04.1 aktualisieren

  • docker.io Ubuntu:22.04:LTS

    Softwareversionen
    • 20.10.7-0ubuntu5
    • 20.10.7-0ubuntu7
    • 20.10.12-0ubuntu1
    • 20.10.12-0ubuntu2
    • 20.10.12-0ubuntu3
    • 20.10.12-0ubuntu3+gke1.24.1
    • 20.10.12-0ubuntu4
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 20.10.21-0ubuntu1~22.04.2

    Auf 20.10.21-0ubuntu1~22.04.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →