CVE-2022-39374
CVE-2022-39374 · Synapse Denial of service due to incorrect application of event authorization rules during state resolution
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Synapse is an open-source Matrix homeserver written and maintained by the Matrix.org Foundation. If Synapse and a malicious homeserver are both joined to the same room, the malicious homeserver can trick Synapse into accepting previously rejected events into its view of the current state of that room. This can be exploited in a way that causes all further messages and state changes sent in that room from the vulnerable homeserver to be rejected. This issue has been patched in version 1.68.0
CVSS 6.5 · Mittel · EPSS 0,9% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
synapse
- Softwareversionen
- >= 1.62.0, < 1.68.0: Betroffen
Keine Korrektur veröffentlicht
matrix-synapse PyPI
- Softwareversionen
- 1.62.0
- 1.63.0
- 1.63.0rc1
- 1.63.1
- 1.64.0
- 1.64.0rc1
- 1.64.0rc2
- 1.65.0
- 1.65.0rc1
- 1.65.0rc2
- 1.66.0
- 1.66.0rc1
- 1.66.0rc2
- 1.67.0
- 1.67.0rc1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.62.0, < 1.68.0rc1
Auf 1.68.0rc1 aktualisieren
matrix-synapse PyPI
- Softwareversionen
- 1.62.0
- 1.63.0
- 1.63.0rc1
- 1.63.1
- 1.64.0
- 1.64.0rc1
- 1.64.0rc2
- 1.65.0
- 1.65.0rc1
- 1.65.0rc2
- 1.66.0
- 1.66.0rc1
- 1.66.0rc2
- 1.67.0
- 1.67.0rc1
- 1.68.0rc1
- 1.68.0rc2
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.62.0, < 1.68.0
Auf 1.68.0 aktualisieren
matrix-synapse Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 1.3.0-1
- 1.4.0-1
- 1.5.0-1
- 1.5.1-1
- 1.6.0-1
- 1.6.1-1
- 1.7.0-2
- 1.7.1-1
- 1.7.2-1
- 1.7.3-1
- 1.8.0-1
- 1.9.0-1
- 1.9.1-1
- 1.10.0-1
- 1.10.0-2
- 1.11.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.11.0-1ubuntu0.1~esm2
Auf 1.11.0-1ubuntu0.1~esm2 aktualisieren
matrix-synapse Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 1.39.0-1
- 1.47.0-2
- 1.47.1-1
- 1.48.0-1
- 1.49.0-1
- 1.49.2-1
- 1.50.1-1
- 1.50.2-1
- 1.51.0-1
- 1.52.0-1
- 1.53.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.53.0-1ubuntu0.1~esm2
Auf 1.53.0-1ubuntu0.1~esm2 aktualisieren