p PatchFirst

CVE-2022-46651

CVE-2022-46651 · Apache Airflow: Security vulnerability on AirFlow Connections

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Apache Airflow, versions before 2.6.3, is affected by a vulnerability that allows an unauthorized actor to gain access to sensitive information in Connection edit view. This vulnerability is considered low since it requires someone with access to Connection resources specifically updating the connection to exploit it. Users should upgrade to version 2.6.3 or later which has removed the vulnerability.

CVSS 7.1 · Hoch · EPSS 1,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • apache airflow

    Softwareversionen
    • ≥ 0, < 2.6.3: Betroffen (semver)

    Auf 2.6.3 aktualisieren

  • apache-airflow PyPI

    Softwareversionen
    • 1.10.0
    • 1.10.1
    • 1.10.10
    • 1.10.10rc1
    • 1.10.10rc2
    • 1.10.10rc3
    • 1.10.10rc4
    • 1.10.10rc5
    • 1.10.11
    • 1.10.11rc1
    • 1.10.11rc2
    • 1.10.12
    • 1.10.12rc1
    • 1.10.12rc2
    • 1.10.12rc3
    • 1.10.12rc4
    • 1.10.13
    • 1.10.13rc1
    • 1.10.14
    • 1.10.14rc1
    • 1.10.14rc2
    • 1.10.14rc3
    • 1.10.14rc4
    • 1.10.15
    • 1.10.15rc1
    • 1.10.1b1
    • 1.10.1rc2
    • 1.10.2
    • 1.10.2b2
    • 1.10.2rc1
    • 1.10.2rc2
    • 1.10.2rc3
    • 1.10.3
    • 1.10.3b1
    • 1.10.3b2
    • 1.10.3rc1
    • 1.10.3rc2
    • 1.10.4
    • 1.10.4b2
    • 1.10.4rc1
    • 1.10.4rc2
    • 1.10.4rc3
    • 1.10.4rc4
    • 1.10.4rc5
    • 1.10.5
    • 1.10.5rc1
    • 1.10.6
    • 1.10.6rc1
    • 1.10.6rc2
    • 1.10.7
    • 1.10.7rc1
    • 1.10.7rc2
    • 1.10.7rc3
    • 1.10.8
    • 1.10.8rc1
    • 1.10.9
    • 1.10.9rc1
    • 1.8.1
    • 1.8.2
    • 1.8.2rc1
    • 1.9.0
    • 2.0.0
    • 2.0.0b1
    • 2.0.0b2
    • 2.0.0b3
    • 2.0.0rc1
    • 2.0.0rc2
    • 2.0.0rc3
    • 2.0.1
    • 2.0.1rc1
    • 2.0.1rc2
    • 2.0.2
    • 2.0.2rc1
    • 2.1.0
    • 2.1.0rc1
    • 2.1.0rc2
    • 2.1.1
    • 2.1.1rc1
    • 2.1.2
    • 2.1.2rc1
    • 2.1.3
    • 2.1.3rc1
    • 2.1.4
    • 2.1.4rc1
    • 2.1.4rc2
    • 2.2.0
    • 2.2.0b1
    • 2.2.0b2
    • 2.2.0rc1
    • 2.2.1
    • 2.2.1rc1
    • 2.2.1rc2
    • 2.2.2
    • 2.2.2rc1
    • 2.2.2rc2
    • 2.2.3
    • 2.2.3rc1
    • 2.2.3rc2
    • 2.2.4
    • 2.2.4rc1
    • 2.2.5
    • 2.2.5rc1
    • 2.2.5rc2
    • 2.2.5rc3
    • 2.3.0
    • 2.3.0b1
    • 2.3.0rc1
    • 2.3.0rc2
    • 2.3.1
    • 2.3.1rc1
    • 2.3.2
    • 2.3.2rc1
    • 2.3.2rc2
    • 2.3.3
    • 2.3.3rc1
    • 2.3.3rc2
    • 2.3.3rc3
    • 2.3.4
    • 2.3.4rc1
    • 2.4.0
    • 2.4.0b1
    • 2.4.0rc1
    • 2.4.1
    • 2.4.1rc1
    • 2.4.2
    • 2.4.2rc1
    • 2.4.3
    • 2.4.3rc1
    • 2.5.0
    • 2.5.0rc1
    • 2.5.0rc2
    • 2.5.0rc3
    • 2.5.1
    • 2.5.1rc1
    • 2.5.1rc2
    • 2.5.2
    • 2.5.2rc1
    • 2.5.2rc2
    • 2.5.3
    • 2.5.3rc1
    • 2.5.3rc2
    • 2.6.0
    • 2.6.0b1
    • 2.6.0rc1
    • 2.6.0rc2
    • 2.6.0rc3
    • 2.6.0rc4
    • 2.6.0rc5
    • 2.6.1
    • 2.6.1rc1
    • 2.6.1rc2
    • 2.6.1rc3
    • 2.6.2
    • 2.6.2rc1
    • 2.6.2rc2
    • 2.6.3rc1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.6.3

    Auf 2.6.3 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →