p PatchFirst

CVE-2023-22457

CVE-2023-22457 · org.xwiki.contrib:application-ckeditor-ui vulnerable to Remote Code Execution via Cross-Site Request Forgery

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

CKEditor Integration UI adds support for editing wiki pages using CKEditor. Prior to versions 1.64.3,t he `CKEditor.HTMLConverter` document lacked a protection against Cross-Site Request Forgery (CSRF), allowing to execute macros with the rights of the current user. If a privileged user with programming rights was tricked into executing a GET request to this document with certain parameters (e.g., via an image with a corresponding URL embedded in a comment or via a redirect), this would allow arbitrary remote code execution and the attacker could gain rights, access private information or impact the availability of the wiki. The issue has been patched in the CKEditor Integration version 1.64.3. This has also been patched in the version of the CKEditor integration that is bundled starting with XWiki 14.6 RC1. There are no known workarounds for this other than upgrading the CKEditor integration to a fixed version.

CVSS 9.1 · Kritisch · EPSS 19,3%

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • application-ckeditor

    Softwareversionen
    • < 1.64.3: Betroffen

    Keine Korrektur veröffentlicht

  • ldap-account-manager Ubuntu:16.04:LTS

    Softwareversionen
    • 4.9-1
    • 5.1-1
    • 5.2-1
    • 5.2-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • request-tracker4 Ubuntu:16.04:LTS

    Softwareversionen
    • 4.2.11-2
    • 4.2.12-3
    • 4.2.12-4
    • 4.2.12-5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ckeditor3 Ubuntu:18.04:LTS

    Softwareversionen
    • 3.6.6.1+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ldap-account-manager Ubuntu:18.04:LTS

    Softwareversionen
    • 5.7-1
    • 6.1-1
    • 6.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • request-tracker4 Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 4.4.1-5
    • 4.4.2-1
    • 4.4.2-2
    • 4.4.2-2ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ckeditor3 Ubuntu:20.04:LTS

    Softwareversionen
    • 3.6.6.1+dfsg-3
    • 3.6.6.1+dfsg-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ldap-account-manager Ubuntu:20.04:LTS

    Softwareversionen
    • 6.7-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • request-tracker4 Ubuntu:20.04:LTS

    Softwareversionen
    • 4.4.3-2
    • 4.4.3-2+deb10u3build0.20.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ckeditor3 Ubuntu:22.04:LTS

    Softwareversionen
    • 3.6.6.1+dfsg-7
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ldap-account-manager Ubuntu:22.04:LTS

    Softwareversionen
    • 7.5-1
    • 7.7-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • request-tracker4 Ubuntu:22.04:LTS

    Softwareversionen
    • 4.4.4+dfsg-2ubuntu1
    • 4.4.4+dfsg-2ubuntu1.22.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ckeditor3 Ubuntu:24.04:LTS

    Softwareversionen
    • 3.6.6.1+dfsg-7
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ldap-account-manager Ubuntu:24.04:LTS

    Softwareversionen
    • 8.3-1
    • 8.5-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • request-tracker4 Ubuntu:24.04:LTS

    Softwareversionen
    • 4.4.4+dfsg-2ubuntu1
    • 4.4.4+dfsg-2ubuntu2
    • 4.4.7+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ldap-account-manager Ubuntu:25.10

    Softwareversionen
    • 9.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • request-tracker4 Ubuntu:25.10

    Softwareversionen
    • 4.4.7+dfsg-4syncable1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ldap-account-manager Ubuntu:26.04:LTS

    Softwareversionen
    • 9.0-1
    • 9.0-1build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • request-tracker4 Ubuntu:26.04:LTS

    Softwareversionen
    • 4.4.7+dfsg-4syncable1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →