CVE-2023-23934
CVE-2023-23934 · Wrkzeug's incorrect parsing of nameless cookies leads to __Host- cookies bypass
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Werkzeug is a comprehensive WSGI web application library. Browsers may allow "nameless" cookies that look like `=value` instead of `key=value`. A vulnerable browser may allow a compromised application on an adjacent subdomain to exploit this to set a cookie like `=__Host-test=bad` for another subdomain. Werkzeug prior to 2.2.3 will parse the cookie `=__Host-test=bad` as __Host-test=bad`. If a Werkzeug application is running next to a vulnerable or malicious subdomain which sets such a cookie using a vulnerable browser, the Werkzeug application will see the bad cookie value but the valid cookie key. The issue is fixed in Werkzeug 2.2.3.
CVSS 2.6 · Niedrig · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
werkzeug
- Softwareversionen
- < 2.2.3: Betroffen
Keine Korrektur veröffentlicht
python-werkzeug Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.2.2-3
Auf 2.2.2-3 aktualisieren
python-werkzeug Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.2.2-3
Auf 2.2.2-3 aktualisieren
python-werkzeug Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.2.2-3
Auf 2.2.2-3 aktualisieren
werkzeug PyPI
- Softwareversionen
- 0.1
- 0.10
- 0.10.1
- 0.10.2
- 0.10.3
- 0.10.4
- 0.11
- 0.11.1
- 0.11.10
- 0.11.11
- 0.11.12
- 0.11.13
- 0.11.14
- 0.11.15
- 0.11.2
- 0.11.3
- 0.11.4
- 0.11.5
- 0.11.6
- 0.11.7
- 0.11.8
- 0.11.9
- 0.12
- 0.12.1
- 0.12.2
- 0.13
- 0.14
- 0.14.1
- 0.15.0
- 0.15.1
- 0.15.2
- 0.15.3
- 0.15.4
- 0.15.5
- 0.15.6
- 0.16.0
- 0.16.1
- 0.2
- 0.3
- 0.3.1
- 0.4
- 0.4.1
- 0.5
- 0.5.1
- 0.6
- 0.6.1
- 0.6.2
- 0.7
- 0.7.1
- 0.7.2
- 0.8
- 0.8.1
- 0.8.2
- 0.8.3
- 0.9
- 0.9.1
- 0.9.2
- 0.9.3
- 0.9.4
- 0.9.5
- 0.9.6
- 1.0.0
- 1.0.0rc1
- 1.0.1
- 2.0.0
- 2.0.0rc1
- 2.0.0rc2
- 2.0.0rc3
- 2.0.0rc4
- 2.0.0rc5
- 2.0.1
- 2.0.2
- 2.0.3
- 2.1.0
- 2.1.1
- 2.1.2
- 2.2.0
- 2.2.0a1
- 2.2.1
- 2.2.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.2.3
Auf 2.2.3 aktualisieren
werkzeug PyPI
- Softwareversionen
- 0.1
- 0.10
- 0.10.1
- 0.10.2
- 0.10.3
- 0.10.4
- 0.11
- 0.11.1
- 0.11.10
- 0.11.11
- 0.11.12
- 0.11.13
- 0.11.14
- 0.11.15
- 0.11.2
- 0.11.3
- 0.11.4
- 0.11.5
- 0.11.6
- 0.11.7
- 0.11.8
- 0.11.9
- 0.12
- 0.12.1
- 0.12.2
- 0.13
- 0.14
- 0.14.1
- 0.15.0
- 0.15.1
- 0.15.2
- 0.15.3
- 0.15.4
- 0.15.5
- 0.15.6
- 0.16.0
- 0.16.1
- 0.2
- 0.3
- 0.3.1
- 0.4
- 0.4.1
- 0.5
- 0.5.1
- 0.6
- 0.6.1
- 0.6.2
- 0.7
- 0.7.1
- 0.7.2
- 0.8
- 0.8.1
- 0.8.2
- 0.8.3
- 0.9
- 0.9.1
- 0.9.2
- 0.9.3
- 0.9.4
- 0.9.5
- 0.9.6
- 1.0.0
- 1.0.0rc1
- 1.0.1
- 2.0.0
- 2.0.0rc1
- 2.0.0rc2
- 2.0.0rc3
- 2.0.0rc4
- 2.0.0rc5
- 2.0.1
- 2.0.2
- 2.0.3
- 2.1.0
- 2.1.1
- 2.1.2
- 2.2.0
- 2.2.0a1
- 2.2.1
- 2.2.2
- Betroffene Versionsbereiche
- GIT: < cf275f42acad1b5950c50ffe8ef58fe62cdce028
- ECOSYSTEM: < 2.2.3
Auf 2.2.3 aktualisieren
python-werkzeug Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 0.10.4+dfsg1-1ubuntu1
- 0.10.4+dfsg1-1ubuntu1.1
- 0.10.4+dfsg1-1ubuntu1.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.10.4+dfsg1-1ubuntu1.2+esm1
Auf 0.10.4+dfsg1-1ubuntu1.2+esm1 aktualisieren
python-werkzeug Ubuntu:18.04:LTS
- Softwareversionen
- 0.12.2+dfsg1-2
- 0.13+dfsg1-1
- 0.14.1+dfsg1-1
- 0.14.1+dfsg1-1ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.14.1+dfsg1-1ubuntu0.2
Auf 0.14.1+dfsg1-1ubuntu0.2 aktualisieren
python-werkzeug Ubuntu:20.04:LTS
- Softwareversionen
- 0.14.1+dfsg1-4
- 0.15.6+dfsg1-1
- 0.16.0+dfsg1-1
- 0.16.1+dfsg1-1ubuntu1
- 0.16.1+dfsg1-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.16.1+dfsg1-2ubuntu0.1
Auf 0.16.1+dfsg1-2ubuntu0.1 aktualisieren
python-werkzeug Ubuntu:22.04:LTS
- Softwareversionen
- 1.0.1+dfsg1-2
- 2.0.2+dfsg1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.0.2+dfsg1-1ubuntu0.22.04.1
Auf 2.0.2+dfsg1-1ubuntu0.22.04.1 aktualisieren
Originalquellen
- https://github.com/pallets/werkzeug/security/advisories/GHSA-px8h-6qxv-m22q
- https://github.com/pallets/werkzeug/commit/cf275f42acad1b5950c50ffe8ef58fe62cdce028
- https://github.com/pallets/werkzeug/releases/tag/2.2.3
- https://www.debian.org/security/2023/dsa-5470
- https://security.netapp.com/advisory/ntap-20230818-0003/
- https://nvd.nist.gov/vuln/detail/CVE-2023-23934