p PatchFirst

CVE-2023-27534

CVE-2023-27534

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A path traversal vulnerability exists in curl <8.0.0 SFTP implementation causes the tilde (~) character to be wrongly replaced when used as a prefix in the first path element, in addition to its intended use as the first element to indicate a path relative to the user's home directory. Attackers can exploit this flaw to bypass filtering or execute arbitrary code by crafting a path like /~2/foo while accessing a server with a specific user.

CVSS 8.8 · Hoch · EPSS 2,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • https://github.com/curl/curl

    Softwareversionen
    • Fixed in 8.0.0: Betroffen

    Keine Korrektur veröffentlicht

  • curl Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.88.1-7

    Auf 7.88.1-7 aktualisieren

  • curl Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.88.1-7

    Auf 7.88.1-7 aktualisieren

  • curl Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.88.1-7

    Auf 7.88.1-7 aktualisieren

  • curl Ubuntu:18.04:LTS

    Softwareversionen
    • 7.55.1-1ubuntu2
    • 7.55.1-1ubuntu2.1
    • 7.57.0-1ubuntu1
    • 7.58.0-2ubuntu1
    • 7.58.0-2ubuntu2
    • 7.58.0-2ubuntu3
    • 7.58.0-2ubuntu3.1
    • 7.58.0-2ubuntu3.2
    • 7.58.0-2ubuntu3.3
    • 7.58.0-2ubuntu3.5
    • 7.58.0-2ubuntu3.6
    • 7.58.0-2ubuntu3.7
    • 7.58.0-2ubuntu3.8
    • 7.58.0-2ubuntu3.9
    • 7.58.0-2ubuntu3.10
    • 7.58.0-2ubuntu3.12
    • 7.58.0-2ubuntu3.13
    • 7.58.0-2ubuntu3.14
    • 7.58.0-2ubuntu3.15
    • 7.58.0-2ubuntu3.16
    • 7.58.0-2ubuntu3.17
    • 7.58.0-2ubuntu3.18
    • 7.58.0-2ubuntu3.19
    • 7.58.0-2ubuntu3.20
    • 7.58.0-2ubuntu3.21
    • 7.58.0-2ubuntu3.22
    • 7.58.0-2ubuntu3.23
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.58.0-2ubuntu3.24

    Auf 7.58.0-2ubuntu3.24 aktualisieren

  • curl Ubuntu:20.04:LTS

    Softwareversionen
    • 7.65.3-1ubuntu3
    • 7.65.3-1ubuntu4
    • 7.66.0-1ubuntu1
    • 7.67.0-2ubuntu1
    • 7.68.0-1ubuntu1
    • 7.68.0-1ubuntu2
    • 7.68.0-1ubuntu2.1
    • 7.68.0-1ubuntu2.2
    • 7.68.0-1ubuntu2.4
    • 7.68.0-1ubuntu2.5
    • 7.68.0-1ubuntu2.6
    • 7.68.0-1ubuntu2.7
    • 7.68.0-1ubuntu2.10
    • 7.68.0-1ubuntu2.11
    • 7.68.0-1ubuntu2.12
    • 7.68.0-1ubuntu2.13
    • 7.68.0-1ubuntu2.14
    • 7.68.0-1ubuntu2.15
    • 7.68.0-1ubuntu2.16
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.68.0-1ubuntu2.18

    Auf 7.68.0-1ubuntu2.18 aktualisieren

  • curl Ubuntu:22.04:LTS

    Softwareversionen
    • 7.74.0-1.3ubuntu2
    • 7.74.0-1.3ubuntu3
    • 7.80.0-3
    • 7.81.0-1
    • 7.81.0-1ubuntu1.1
    • 7.81.0-1ubuntu1.2
    • 7.81.0-1ubuntu1.3
    • 7.81.0-1ubuntu1.4
    • 7.81.0-1ubuntu1.6
    • 7.81.0-1ubuntu1.7
    • 7.81.0-1ubuntu1.8
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.81.0-1ubuntu1.10

    Auf 7.81.0-1ubuntu1.10 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →